The live update connection is taking longer than expect.

Answered

Hello,

 

We have begun using YouTrack (fantastic application by the way) and so far has been a pretty easy experience. We are pretty much set except this one particular problem.

 

Anytime I visit the Agile Board page I get the following message after a few moments:

We do not have a reverse proxy setup nor do (I think) we need one since this is self hosted for our company. I have searched through the help pages for the disabled buffering option but I am unable to find it. I did look in our logs and found the following in C:\ProgramData\JetBrains\YouTrack\logs\youtrack\logs\liveupdate-debug.log. The below message occurs every time this notification appears. 

I know live updates are a fairly new feature in YouTrack and we are on version 7.0 build Build 29566.

3 comments
Comment actions Permalink
Official comment

Hello Brian, could you please submit a request into our support system (using form: https://youtrack-support.jetbrains.com/hc/en-us/requests/new?ticket_form_id=66282) and provide there:
1) a screenshot of your browser console when you see that error popup
2) a HAR file recorded from the opening of the board and up to the moment when the error appears
Instructions for recording a HAR are here, p.3: https://youtrack-support.jetbrains.com/hc/en-us/articles/206546369-When-we-ask-you-to-provide-additional-details-logs-database-HAR-etc-

Thank you!

Comment actions Permalink

Hi Liubov,

I have submitted a ticket with the information requested. Thank you! :)

0
Comment actions Permalink

Solved!

For anyone that comes across this, for our particular setup we just had it under HTTP and did not have our HTTPS only instance setup quite yet. Turns out that Bitdefender Endpoint Security Point (The current version we are on is https://www.bitdefender.com/support/bitdefender-endpoint-security-tools-version-6-2-17-876-release-notes-1818.html) was somehow blocking the live update traffic under HTTP. The crappy part is within the console, no logs show this being actively blocked. Uninstalling Bitdefender worked. No matter what exception was made within the console for our local YouTrack install, it simply would not work. Switching to HTTPS fixed this since it cannot detect the encrypted traffic.

TL;DR Switch over to HTTPS if you haven't already done so. Best practice! Thank you JetBrains support!

0

Please sign in to leave a comment.