email integration not collecting emails.

Hi all,

We've had an issue for a few days now where emails into our ticket inbox are not being picked up by YouTrack and turned into tickets.

All users that have sent emails have create rights on the default project ("inbox" in this instance).

I have checked the mail log and it says:

17 Mar 2017 11:04:50,884 INFO [MailboxImpl ] [tzJobProcessor1] [] Processed 0 messages from INBOX
17 Mar 2017 11:04:50,886 INFO [MailboxImpl ] [tzJobProcessor1] [] Finished mail fetching
17 Mar 2017 11:10:00,001 INFO [MailboxImpl ] [tzJobProcessor2] [] Start mail fetching
17 Mar 2017 11:10:00,792 INFO [MailboxImpl ] [tzJobProcessor2] [] Resolving folder INBOX
17 Mar 2017 11:10:00,793 INFO [MailboxImpl ] [tzJobProcessor2] [] Processing folder INBOX...
17 Mar 2017 11:10:45,834 INFO [MailboxImpl ] [tzJobProcessor2] [] Processed 0 messages from INBOX
17 Mar 2017 11:10:45,888 INFO [MailboxImpl ] [tzJobProcessor2] [] Finished mail fetching
17 Mar 2017 11:11:43,609 INFO [MailboxImpl ] [tzJobProcessor3] [] Start mail fetching
17 Mar 2017 11:11:44,812 INFO [MailboxImpl ] [tzJobProcessor3] [] Resolving folder INBOX
17 Mar 2017 11:11:44,813 INFO [MailboxImpl ] [tzJobProcessor3] [] Processing folder INBOX...

Etc... At this point there were about 40 emails in the inbox.

Suddenly, after a delay of 20 hours, about 30 of these were converted to tickets.

There are still some in there waiting - the users that have sent them have other tickets that were created so they have rights to create tickets - I have set the default user for those not registered. Some of those have been converted while others have not.

There are no errors in any logs.

The schedule to collect emails is set to 10 minutes, but this doesn't appear to do anything.

 

 

 

 

 

 

 

7 comments
Comment actions Permalink

Hello,

If you open Administration > Mailbox integration, and then choose "Test connection", will it be successful?

 

0
Comment actions Permalink

Hi, thanks for the reply. Yes, if I click Test Connection, it completes with "Connection test passed".

 

0
Comment actions Permalink

Hi, still happening. The message says: Processed 0 messages from INBOX (2 hours and 33 minutes ago)

The auto collection interval is set to 10 minutes.

There are messages in the inbox waiting to be picked up.

 

Any ideas?

 

0
Comment actions Permalink

David, I'm sorry for the delay.

Does the issue persist? Could you please share your full logs with us? You can upload your logs to the FTP: ftp://ftp.intellij.net/.uploads/ and then write the name of the archive here or to youtrack-feedback@jetbrains.com

Also please let us know the build number that you're using.

Thank you.

0
Comment actions Permalink

A little hint, I have this problem since 3 years.

It seems that emails send from the same mailserver where the inbox is located are ignored most of the times (in some rare cases the emails are found and imported). There are also cases where mails got imported but not deleted from the mailbox, in the logs are no errors related to mail integration but you can find out if you check the issues one by one and compare with the emails still in the mailbox.

I end up doing this once a week and manually delete the emails if already imported and manually create issues and also delete the emails if not imported.

0
Comment actions Permalink

Something I just got aware of.

It seems that this is happening if there is no message-id in the email header. After finding that out and force postfix to add a message-id my first three test emails got imported without problems. Maybe that was the problem after all.
If that is the reason this is a little bug in youtrack since message-id is an optional header. At least it should be mentioned in the documentation

0
Comment actions Permalink

I had the same issue - thanks to this thread, I've added:

 

always_add_missing_headers = yes

 

to main.cf to my postfix setup and reloaded it - bingo, it works! thanks guys! Windows 10 machines using the standard "Mail" client were guilty of sending emails with the missing Message-ID header.

0

Please sign in to leave a comment.