Setup Fails Starting Service

I was running 6.5 fine until I tried to upgrade to 2017.2. The problem is that the installation fails saying: Service 'JetBrains YouTrack' (YouTrack) failed to start. Verify that you have sufficient privileges to start system services.

I'm connected to the server where this is running as an account that's part of the Administrators group, and I effectively can start and stop other services. I can see that the new YouTrack service no longer runs under "Local System", but the service now Logs On as ./JetBrainsYouTrack user. If I manually try to start the service it would say something like "the service started and stopped automatically, it could happen because nothing was actually using it"

To make matters worse, the rollback of the attempted install messed something up so my old 6.5 version is not starting back up either.

I tried uninstalling all YouTrack versions and removing the local directories (C:\YouTrack and C:\ProgramData\JetBrains\YouTrack) to perform a "clean" install with no luck. 2017.2 nor 6.5 are able to get installed at all, and since the starting of the server is part of the setup process, when I cancel it basically uninstalls anything it tried to do.

This is becoming an act of frustration since apparently nothing I'm trying (and I've tried many things during the past couple of days) seems to be helping.

1 comment

Finally was able to figure this one out.

First had to change an installation xml to not try to use port 8082 and use another one of my choosing (why this is still not a parameter is beyond me).

Then the service still wouldn't start, which I think is potentially related to the fact that it's trying to Log On as a local user, and our GPO might be limiting non-admin accounts privileges. So while in the "retry" stage, I opened the Services Control Panel and changed the Log On for the YouTrack service to be Local System, and manually started the service, which worked. After that setup was able to finish and I was able to manually navigate to the startup screen that allowed me to Upgrade from the backup I had of my old 6.5 instance. Again, I had to manually navigate because setup automatically navigated to which is not where my YouTrack service was running.

Hope this helps someone else if they run into this bizarre combination of events that lead to a couple of days of fury.


Please sign in to leave a comment.