Merged Fields bizarre behaviour - Unable to edit despite being Admin


In all of our projects we have a common field set for the Squad working on it.

Some of our projects have been mistakenly using independent value sets. I have merged this using the "Merge with" function on the project page, with disastrous results.

Note the new ones prefixed with "Borrowers Tribe - Ladders" - I have tried to delete these and replace with the unprefixed version. There is no error but upon refreshing the values have not been updated.


Orrin, which YouTrack version are you using currently? Does your license allow you to upgrade?




  • JetBrains Bug & Issue Tracker YouTrack 2017.1
  • Build 31650 Tue, 07 Mar 2017 10:02:06 GMT

We're self-hosted. We've been hesitant to upgrade due to the number of bugs and silent changes in expected behaviour introduced in recent versions.



Hey @Liubov, someone in our support team will hopefully send them through sometime soon.

So far I've tried:

- ensuring none of the projects using the fieldset are archived

- Tried deleting the value from the apparent problem-project (Borrowers Tribe - Ladders)

- Made the problem apparent problem project use an independent fieldset (Make independent copy from the project editor)


None have worked. And there are no on-screen alerts of failures when deleting the fields - It is a silent error.


Orrin, it looks like a known issue which should be fixed in your version already. We need to be sure and that's why we're asking for the logs. We'll be able to tell more once we have the logs.

Thanks for understanding.



I've forwarded on logs via a support request, and checked the logs while reproducing the problem.

The fields cannot be deleted/merged due to an arbitrary field setting in an unrelated custom fieldset on another project. The log references a particular YouTrack issue, and even after deleting the problem issue and retriggering the error, the log references the same, now-deleted, card.


This is proving very problematic now as some projects now have a mix of bizarrely-IDed duplicates of some fied values, as well as some instances of non-distinguishable cloned sets of values.

More non-technical users are being onboarded to use YouTrack as a means of project management and organisational transparency, and these errors are very confusing for those users.

The errors are silent, and we've encountered cases of people performing repeat actions without realising they won't persist.

Please help. -> Will a version bump fix this?


Orrin, thanks for the logs, we're investigating them at the moment. I'll let you know when we have updates, I'll write you in the support ticket.

We're sorry for the inconvenience and thank you for understanding. Thank you.


Please sign in to leave a comment.