Problem with missing "Share" button in Dashboard and no options in Report "Visible to"

Hello, 

I am using Standalone YouTrack (Build 35488 9 Aug 2017)


I am having trouble sharing a dashboard with my team. I successfully created a dashboard with a few reports in it and now I want to share it.

Problem 1) I don't have a "Share" button.
I suppose it is a permission I don't have, but I just can't find which permission it is, so I ask the admin to it  to give me.

Problem 2) When I want to select which users/groups should see my report, but in the dropdown "Visible to" I see just one option "Only me"
Maybe it is the same problem?

What might be the reason for this, how can I fix it?

8 comments
Comment actions Permalink
Official comment

Hello,

 

It's the same problem with permissions indeed, you need a permission named "Share tag or saved search". Please let me know, if it helps.

Comment actions Permalink

Thanks, but I already have this permission enabled and I still don't see "Share" button and groups.
Maybe it is some combination of permissions?
Tried disabling and enabling this permission - no change
Now my user is explicitly assigned to the “Developer” role which has the “Share tag or saved search” permission - no change.
Can you give me a more a more specific solution?

0
Comment actions Permalink

COuld you please provide the following screenshot: And the right-upper corner of the dashboard, like: 


About the reports: you should have "Read groups" permission.

0
Comment actions Permalink
0
Comment actions Permalink

I have the HAR file, can you give me an email address, so I can send it there, please :)

0
Comment actions Permalink

Please create a support ticket (on this site in the right upper corner).

0
Comment actions Permalink

I was facing the same issue and I did an extensive exercise of permission assignment and de-assignment to find out which permission is actually deciding the availability of the 'Share' button in dashboard. I found out the following permission:

Roles>Permissions>Application-Hub>Read>Read User

I did not find it necessary to have the sharing tag & saved searches permission to be there along with the above permission to make the 'Share' button available in dashboard. A minimum reported level permissions along with the above permission is enough.

 

0

Please sign in to leave a comment.