Editing workflow with VS Code: Could not find a declaration file for module '@jetbrains/youtrack-scripting-api/entities'


I'm trying to edit wofkflow code with Visual Studio Code and getting the following error:

Could not find a declaration file for module '@jetbrains/youtrack-scripting-api/entities'

I read this article but still can't figure out how to use my IDE correctly.


Hi Viacheslav, this seems to be an issue related to TypeScript. Have you tried the suggestions from the popup message? 



yes, but it does not work:

npm i --save-dev @types/jetbrains__youtrack-scripting-api

I also tried to install this package, but it seems a bit outdated.


Workflows are written in standard JS, and there are no type declarations in the code. It does not seem to make a lot of sense to use TypeScript, unless you plan to create your own declarations in the basic code (such as the entities module). We would suggest disabling TS in the project or using skipLibCheck to avoid checking declarations in this module.


Please sign in to leave a comment.