Workflow jetbrains-youtrack-workTimer reports error: Can not resolve property Issue.

I installed 4.1 and enabled time tracking for a test project that I'd just created.  I then attached the jetbrains-youtrack-workTimer workflow to it.  Now if I try and do anything with that project, I get this error:

Workflow jetbrains-youtrack-workTimer reports error: Can not resolve property Issue. in project JerryTest

What am I missing?
are there docs for 4.1 somewhere???
Workflow editor shows Timer and Timer time in red with a message like: "Error: No reference in role 'fieldDescription' (declared cardinality is 1)"
FIgured out what's wrong. Bundled workflows require Timer and Timer time fields for every issue to work. There's no any mentioned about them. Found tickets that shed a light: JT-17008 and JT-15494. So to implement a timer on you project you have either create these fields and start/stop timer manually. Or update rules to track changes in issue and start/stop timer automatically.
Unfortunately the problem about Issue property originally noted still persist when fields are added
Here's a stack trace from the error log
YT_WF_StackTrace.txt (15KB)
This is when I tried to assign an issue to myself w/ the workflow attached.
Hi Jerry, Eduard,

did you add fields 'Timer' and 'Timer time' as this workflow requires? Without these fields the workflow won't start.
Yep, these fields are available for a project we're testing on. When I try to start timer I see the message that is originally posted as a problem here.
Screen Shot 2012-11-09 at 11.04.23 AM.png
It seems that the workflow requirements system didn't signalize you about the problems. I'm investigating it.

Please check manually if the field "Timer" of type 'enum[1]' has 2 values "Start" and "Stop" and the field "Timer time" is of type 'date'.
screenshot1 (1).png

It seems you generated the workflow with by the Workflow Editor.
Please use Workflow Editor 4.1.
I had version 4.0 but it doesn't understand at least "period" type so I downloaded 4.1. I forced upload to server from 4.1 version already.
Screen Shot 2012-11-09 at 12.32.22 PM.png

Screen Shot 2012-11-09 at 12.32.39 PM.png
So the error remains?
If yes please attach the workflow "jetbrains-youtrack-workTimer" ('Worfklows' screens > 'Export' in Administration) here.
1. Please confirm you checked 'Timer', 'Timer time' fields configuration as I described above.

2. If you detach 2 mentioned fields the requirement should appear on attaching this workflow and you should be able to apply quick fixes.
screenshot1 (2).png
Checked fields. Detached and attached back workflow without any errors. Detached fields with a warning that workflow will stop working. Verified that rules are underwaved with red when there are no fields. Detached workflow and attached it back. Two suggestions applied. Fields are added with a bit different bundles. Still see the same error.
Screen Shot 2012-11-09 at 1.11.32 PM.png

Screen Shot 2012-11-09 at 1.12.25 PM.png
You need to regenerate the workflow "jetbrains-youtrack-workTimer" by the Workflow Editor 4.1.
For this add e.g. empty line into rule 'time start' or 'time stop' and upload it on server.
Note whether the workflow "jetbrains-youtrack-workTimer" is updated on server.

This should help.
Yep, I see that requirements section is expanded with fields array. Now it works great. Thanks!

Please sign in to leave a comment.