14 comments
Comment actions Permalink
Hello Vasiliy,

Could you please clarify, what changes do you mean?
0
Comment actions Permalink
I mean relocation of database
0
Comment actions Permalink
Vasiliy,

What Tomcat version do you use?
If it's Tomcat7, then execute as follows (with other Tomcat version it may differs, let us know if you use another one):

  • create an .xml file under $CATALINA_BASE/conf/Catalina/[hostname] directory.
  • name this .xml file with YouTrack application name, so it should be youtrack.xml

youtrack.xml file should looks like:
<?xml version="1.0" encoding="UTF-8"?>
<Context>    
    <Parameter name="database.location" value="${user.home}/teamsysdata" override="1"/>
</Context>
prettyPrint();

Thank you.
0
Comment actions Permalink
We have the same problem in a Windows Service installation. Where is this located in a Windows Service installation ?
0
Comment actions Permalink
Hello Erwin,

Try to create youtrack.xml under YouTrack installation directory. As an exanple, path may be the following  C:\Program Files\YouTrack\conf\Catalina\localhost\
Please note, that there is no 'Catalina\localhost' directory by default, so you need to create it by yourself.

Get back to us with results.

Thank you.
0
Comment actions Permalink
Hello, Andrey!

Thank you for the response.
I beleive YT run on tomcat 6, it is 4.2.4 version
0
Comment actions Permalink
Hi Vasiliy,

May I kindly ask you to try this variant on Tomcat6 and get back to us with results? Seems, it should work, too.
0
Comment actions Permalink
Could you please explain what is $CATALINA_BASE?
Is it possible to move database to an external one like MSSQL? I know it is possible for TeamCity and it is cool.
0
Comment actions Permalink
I created file C:\Services\YouTrack\conf\Catalina\localhost\youtrack.xml
and put there a location of my database but it does not work.
So i might have done something wrong. Is there any logs i can look to find out a mistake?
0
Comment actions Permalink
I've created the file, but it is not working. It still uses the old directory. My file looks like:

<?xml version="1.0" encoding="UTF-8"?>
<Context>    
    <Parameter name="database.location" value="C:/Data/YouTrack" override="1"/>
</Context>
prettyPrint();
0
Comment actions Permalink
Hello Erwin, Vasiliy,

Please, execute the same steps, but create the .xml file with the name 'ROOT.xml' .
Solution, that was suggested in http://forum.jetbrains.com/message/YouTrack-1056-3 is actual when you deploy YouTrack as a .war , when it's deplyed under /youtrack context path.
Sorry for that confusion.

Let me know if it doesn't help.
0
Comment actions Permalink
I have the file here now: C:\Program Files (x86)\YouTrack\conf\catalina\localhost\ROOT.xml, but it is still using the old directory.
0
Comment actions Permalink
Hello, Erwin!
For Windows installation you can use following instructions:

1. Stop the service
2. Run from command line: "
%your_YouTrack_location%\bin\tomcat6w.exe //MS//YouTrack"
(This will cause Tomcat webserver properties manager to appear in your Windows system tray)
3. Click on the above mentioned manager and select 'Java' tab
4. Add -Ddatabase.location=%PATH_TO_YOUR_DB%
5. Click OK. This will close the manager (Attention! This feels a bit counter-intuitive, but you really have to close it here)
6. Open the manager once again. On General tab press Start


After it when your deployed youtrack.war, path to database will be %PATH_TO_YOUR_DB%

For deploy new build:
1. stop the service
2. remove old ROOT.war from %your_YouTrack_location%\webapps
3. rename new youtrack.war build to "ROOT.war"
4. copy it to %your_YouTrack_location%\webapps
0
Comment actions Permalink
This worked for me.

One remark: The database location on Windows Server 2012 seems to be changed from YouTrack v5.0.1 to v5.0.2. First our database was located in C:\teamsysdata. After installing the update the database is located in C:\Windows\SysWOW64\config\systemprofile\teamsysdata. I've tried to update YouTrack and couldn't get it running with or old database because I didn't notice this change. With the new fixed database location setting it works ok.

Thnx!
0

Please sign in to leave a comment.