YouTrack needs new setup after server restart + database cannot be restored


We were using the YouTrack version 5.0.3 and switched to 5.0.6.
After the update everything worked fine and we could use the system.
Our database backup runs every sunday, so we have a backup from this Sunday 2014-02-02 (v5.0.6).

Yesterday we had to restart the server (hardware) and after restart, we cannot login in YouTrack.
We are required to newly setup the YouTrack database and all data is actually lost.
When trying to restore the latest backup (from Sunday), the same thing happens, the server stars and asks for a setup, and no data is available. An older backup from the version 5.0.3 also cannot be successfully restored.
We are using the information from this link to restore the data.

Could you please provide a solution to this problem?

Thank you in advance!
1 comment
Ok, I just found a workaround to this issue.
We followed the instructions from (Paragraph "Changing Database Location for EXE Distribution" - our installation is on a W2k8) and explicitly added the parameter "-Ddatabase.location=C:\teamsysdata" to the configuration (our service is running under Local System account). When the YouTrack service restarted, it found the correct path and loaded the database.

It seems that somehow the service "forgot" where the database is located although it worked for a few days after the update to 5.0.6 until we needed to restart the OS.

Maybe it helps somebody...

Please sign in to leave a comment.