Unable to create reports. Get error that says 'Undefined'

I am unable to create reports in YouTrack.

It's the downloaded edition.

When I try to create a report, either in Time or Matrix, I get an error at the top of the screen that says "undefined". This happened in 5.0 and its now in happening 5.1. Any thought on how to fix this issue?

Reports is one of the best features of YouTrack.


Capture.PNG
4 comments
Comment actions Permalink
I'm having this exact same issue and don't know how to get around it.
0
Comment actions Permalink
My instance of YouTrack is setup on port 8080 in Windows. I wanted accessible from the outside and over port 80. I am using Pound to do the translation. For whatever reason the translation is not working correctly. I am not sure if it's a pound issue or a YouTrack issue, but for some reason when creating reports it uses the configured (at least it appears to be) host URL (which is localhost:8080). From the outside (over port 80) it can't be accessed. If you log on to the machine and manage it locally all is good. Once a report is created it can be viewed from the outside url.
0
Comment actions Permalink
I'm running YouTrack+TeamCity on the Tomcat server port 85 behind IIS which provides a HTTPS interface. I think the issue is that the request comes from HTTPS and changes to HTTP when it hits the Tomcat server, and in the logs I can see that an Access Denied page is returned from the Tomcat server which translates to the 'undefined' which we see.

I noticed that in addition to the report, I also can't create a new sprint in an agile board for the same reason. Strange because everything else works fine through the IIS url rewrite/proxy solution. There must be something in those 2 requests which is different.
0
Comment actions Permalink
I changed our setup so that we just use the Tomcat server and no IIS (using this guide http://paulstovell.com/blog/teamcity-ssl-on-windows-with-redirect-from-http) and I setup the tomcat server to use HTTPS instead.

Funny thing is, it's exactly the same still. Everything works but creating a sprint or a report. I can even edit existing reports, just can't create new ones. Crazy.
0

Please sign in to leave a comment.