Can't install & run Youtrack 5.1.2 Release as standalone on my pc (running windows 7)


my name is Omer and I'm an embedded programmer in a small start-up company in Israel.
I'd like to install your issue tracker tool as a standalone on my pc for use of 2-3 people as a web server for issue tracking.

1) I tried to install the windows installation package on the pc. It just installed Youtrack under c:/Program Files and made some windows service run. Accessing locahost / locahost:8080 turned up with nothing. BTW, I pre-installed java jre8 on my computer and set the JAVA_HOME & CATALINA_HOME environment variables as necessary.
It seems as though no tomcat installation is running at all.
2) Therefore I abandoned this installation altogether and tried using my basic web knowledge to do the following:
a. Install a new tomcat server 7.0.53 on my computer with jre 8.
b. Configuring environment settings and tomcat manager settings to point to the new "standalone" installation folders location (has nothing to do with's a standalone tomcat installation).
c. Testing tomcat web server on some basic web application. The server works fine uploading war files and all, running apps as required.
d. I've downloaded the last youtrack war (of version 5.1.2) that was uploaded recently. I've put this file (renaming it to YouTrack.war) in the webapps folder under my <u>tomcat installation folder </u> (different than the non-working one under YouTrack folder as mentioned in 1 above).
e. Tomcat server has extracted whatever zipped in that war file to an appropriate YouTrack folder under webapps.
f. Using tomcat manager I've been able to start YouTrack. I even ran the YouTrack service (probably not necessary in the tactics I tried in 2 here).
g. At last, I've tried to run YouTrack using that manager (or simply surfing http://localhost:8080/YouTrack) and after a long wait it came out with the <b>"HTTP Status 500 - Your database was touched by YouTrack build 8723. Downgrade is denied, please restore your database from backup."</b> error. Please look at the end of this message for full output.

I tried reinstalling and even using different war files but it seem worthless. I've spent more than 10 hours already trying to make this thing work. If there is a possibility that simple windows "exe" installer will fix this somehow it's preferrable. Right now I feel I'm really close but some bug int YouTrack upload (database was touched by YouTrack build 8723) is keeping me from starting using this great app.

Please advise.

Thanks in advance,

The following is the full error output:
HTTP Status 500 - Your database was touched by YouTrack build 8723. Downgrade is denied, please restore your database from backup.

type Exception report

message Your database was touched by YouTrack build 8723. Downgrade is denied, please restore your database from backup.

description The server encountered an internal error that prevented it from fulfilling this request.

java.lang.RuntimeException: Your database was touched by YouTrack build 8723. Downgrade is denied, please restore your database from backup.
    java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    java.util.concurrent.ThreadPoolExecutor$ Source) Source)

note The full stack trace of the root cause is available in the Apache Tomcat/7.0.53 logs.

Apache Tomcat/7.0.53
Comment actions Permalink
Hello Omer!
The error message means that your database was used with the newest YouTrack build and then you are trying to use it with an old one. Few days ago we've released version 5.2. With this version all should be ok.
Comment actions Permalink
Hello Alexander,

First, thank you very much for your response.
I suspected that the problem was the one you've written.
It actually happened on a new installation of Tomcat with version 3.3 and above (in all of them including version 5.2 on a new Tomcat installation). Nothing was changed when installing new version with new youtrack version 5.2 .
I'm not sure to what database this message refers but it won't work (and as I wrote I tried both the windows insaller - which didn't work at all as tomcat didn't run and the application wasn't even loaded, and the standalone war file using my own tomcat application).

Please try to give me another advise to action item that I didn't use already, in order to start and use your app.

Comment actions Permalink
Hi Omer,
The 8723 build is a build of version 5.2. Maybe you're running two versions of YT under Tomcat or Tomcat didn't replace old unpacked files with new ones.
Try cleaning unpacked YT directory (under webapps directory) and then run Tomcat again.
Comment actions Permalink
Hello Alexander,

1) I've already tried all of it as I've written before: I tried using YouTrack 5.2 on a new standalone clean installation of Tomcat 7.0.53 and the problem reoccurred in the same manner. Id doesn't have more that 1 YT application because it's a new installation!

2) Furthermore, I already mentioned that the windows installation (exe file) on my PC isn't working at all as it doesn't even set the Tomcat server (as I've done in a standalone installation on my own, without YouTrack exe file). I can't get why either (and I've set the environment settings to C:\Program Files\YouTrack as necessary and the java installation folder as needed). This should have been the first from-the-box choice for someone who wants to test the YT app quickly. I used my very old knowledge as web developer in trying to install & deploy TOMCAT on my own, and only then downloading YT.war and deploying it on tomcat. This is much more cumbersome, and as I wrote I've already try to do both kind of deployments for a day and a half, including debug & googleing of all issues. It is frustrating.

3) Maybe I'll try calling your sales in the middle east & Europe for direct support, as we're very interested in examining this software as a company (and maybe move later on to upgrade to non-free version of it. But not without trying the free version for a testing period).

Any further help will be appreciated.
Thank you very much for your response.
Comment actions Permalink
Hello Omer,
I read what you had wrote. But the exception you've provided can be thrown in only one case, when YT starts with database that was used with newest YT build. From your first message I see version 5.1.2 and exception that says YT runs with database touched by version 5.2. So, I think the problem is in configuration or in some side effect of installing different versions.
To understand what's going wrong I'd suggest you doing following steps:
  1. Stop and remove Tomcat from your computer.
  2. Stop and remove YT/exe from your computer.
  3. Remove old YT directory (C:\Program Files (x86)\YouTrack) if it was't removed completely.
  4. Go to your home directory and remove directory teamsysdata.
  5. Download latest YT version 5.2 (exe distribution) and install it.
Then send us YT logs if it won't start correctly. Logs can be found under C:\Program Files (x86)\YouTrack\logs.
Comment actions Permalink
Hello Alexander,
Before you wrote I was able to install YT version 5.0 .
Following your plan I've installed YT version 5.2 once again. Browsing http://localhost:8080/login gave me a YT login page !
I'd like to use the below 10 users free version (rather than the 60 free days version), so I enter "root" as user & password as suggested in , but I can't log in. Is it because I'm a free user ?

You've been to a great help thus far and I feel it's close. Running 5.0 version will work, but it seems as version 5.2 is working fine, just missing credentials.

Thank you very very much,
Comment actions Permalink
Hello Omer,
I'm happy you've managed to run YT. As credentials are concerned the default admin pair is root/root. It doesn't matter which license do you use, free or trial.
You can go to http://localhost:8080/login and log in with the credentials. After that you can go to http://localhost:8080/setUp and manage you license.
Comment actions Permalink
Hi Alexander,

Thanks once again.
I found out that the password (for some reason) is 1234.
Now inside setup I'm trying to use the free setting but it seems problematic. It says that :
Parameter    Limit    Current (Update)
User Count    0     3
Project Count    0     1
Issue Count    0     2
Disk Space    0.0 MB     4.0 MB
Ban Guest    Allowed    
License expiration date    01 Jan 1970

Something seems wrong. It should have 10 users and the project count and issue count not-limited, isn't ?
2 issues seems like I couldn't even start to work with it.
What am I missing? The free version has only one project and 2 issues (2 bugs) ?
Comment actions Permalink
Hello Alexander,

It seem like there was some old installation (2 years old) that someone has installed on my PC. It explains many of the problem including the numbers I've just written above (he opened 1 project with 2 issues).
I'll try to re-set it and stop asking questions (at least try :) ).

Comment actions Permalink
Hi Omer,
Hm, could you please try clicking Update link in License Limitations table header.
If it doesn't help then please attach screenshot of settings page.
Comment actions Permalink
BTW, there should be button Switch to YouTrack Free Pack that allows you to switch to free license with 10 users

Please sign in to leave a comment.