YouTrack 6 - Root Account won't reset [MSI]

Hi All,

Really stuck now!
followed quite a few suggestions from here and pretty much giving up now.

Problem I have is I managed to remove the admin account and cannot get root to 'reset' back to the right privileges.

YT 6 just upgraded from YT 5.2.5
It's installed on a windows server via MSI

Tried the following:
1) Added '-Djetbrains.charisma.restoreRootPassword=true' to youtrack.jvmoptions in C:\ProgramData\JetBrains\YouTrack\conf\

2) sc start youtrack -Djetbrains.charisma.restoreRootPassword=true

I'm out of ideas, I even read this: https://confluence.jetbrains.com/display/YTD6/Changing+or+Restoring+Password+and+Permissions+for+Root
and that didn't work either, YT6 seems to be really broken, or just the reset feature hasn't been tested with the new db upgrade?
4 comments
Comment actions Permalink
Hi Tim,

What did you exactly do with the root account?
Did you stop YouTrack service before adding the parameter?
What did you observe when run YouTrack? Did you try to log in with default credentials: root/root?
0
Comment actions Permalink

I was having issues on a new project we created with permissions. So being a bit stupid I decided to clean up some roles (remove some that didn't have a comment). I removed the admin role account. Which is my issue now.

I have stopped and restarted the service several times, sometimes the service takes forever to come back up, but does eventually come back alive. But the root account doesn't have the password or permissions updated to the default again.

Root/root doesn't work, the same credentials from before still work (not reset).

I can provide the DB or other files if needed to you.
0
Comment actions Permalink
Even better (sarcasm).
Having tried to reset the password using the provided (wrong or doesn't work documentation of https://confluence.jetbrains.com/display/YTD6/Changing+or+Restoring+Password+and+Permissions+for+Root)
The original root password I could login now no longer works, nor the root/root. So now Root has somehow gone.

Growing tired of trying to fix this, and now considering other agile boards. This is a shame, as I have been a big admirer of YouTrack until the latest upgrade. All I can say for people on 5.2.5, is:
  • !DO NOT UPGRADE to YouTrack V6 until it's stable!-

When you have completed your upgrade, everything looks fine, until you try and add a new project and no user permissions can be set on it, so you fiddle with the accounts and then wreck it.

Oh well, a couple more hours trying to fix it before it gets permanently removed from our development cycle and replaced with something more reliable, I hope..

If I work out a solution I will post back, but I doubt it's possible without starting again!
0
Comment actions Permalink
I managed to fix the issues. By the looks of it (i don't know why) but it appears there are 'two' user account systems. Fortunately I have managed to use a user account which had enough permissions to add everything back, but the document published in the YT docs did nothing.

The 'User account' system for YT I had to login to rather than the hub, or something weird (lucky that i checked other login's).
0

Please sign in to leave a comment.