Error updating YT 5.2.5 (8823) to 6.0 (12463)

Hello,

We are trying to update our YT from 5.2.5 to 6.0

Follow this instructions:
https://confluence.jetbrains.com/display/YTD6/Upgrade+Instructions

As we have in the 5.2.5, we changed the /jetbrains/mps/webr/standalone/runtime/standalone.xml and add <Set name="host">track.xxxxx.xx</Set>.

But when we try to start the YT we are getting this error on the log:

17:36:57,557 ERROR [ServletImpl    ] [init servlet   ] [] Can't init servlet
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'ringBundleSettings' defined in file [/home/youtrack/.youtrack/work/jetty-0.0.0.0-8112-youtrack.jar--any-/webapp/WEB-INF/classes/jetbrains-spring-configuration/jetbrains/youtrack/ring/settings/ringSettingsConfiguration.xml]: Instantiation of bean failed; nested exception is org.springframework.beans.factory.BeanDefinitionStoreException: Factory method [public jetbrains.exodus.entitystore.Entity jetbrains.teamsys.dnq.runtime.util.EntityFactory.getOrCreate(java.lang.String)
] threw exception; nested exception is java.lang.RuntimeException: jetbrains.exodus.database.exceptions.ConstraintsValidationException: Constrains validation exception. Causes:
  1: url should be valid url but was track.xxxxx.xx/hub

track.xxxxx.xx -> Here we have the real url, just masking for the thread.


We use LDAP integration.

Thanks in advance for your help.

Please sign in to leave a comment.