No chance to use a self-signed certificate to access Youtrack via https?


does anybody understand why I have this access problem (s. screenshot below) during the installation process?
Immediately after my key pair is accepted (pressing 'next') it's returned (Chrome browser):
"Service is not accessible from your browser by given URL.":

Do I maybe have to import my self-signed certificate into the browser manually? I hope not!...
Instead I would expect a brwoser warning and the possibility to choose an exception. Do you agree?...

At that I just followed the instructions at
and .

Thank you very much for your help!

Comment actions Permalink

I now upgraded Youtrack without the certificate on base of http setting.
Afterwards I imported the self-signed certificate in Youtrack as a trusted one.

How do I have to change over to a https connection now?...

Comment actions Permalink

@Lüba: Thank you for that link which describes the right things. BUT unfortunately it doesn't suit with my screen. E.g. I cannot find the option Administration -> Domain Settings -> Base URL but only Global Settings -> Base URL.

Furtheron there is NO "corresponding fields" to fill in SSL Private Key and Certificates! Nowhere, although I have role and rights of a system admin!! 

There is no menue point 'Administration' at all although the rights of 'system admin' include all available rights, so also 'Low-level Administration permissions' which is necessary to show the 'administration' menue option!...
So what can be wrong here?...

Comment actions Permalink

Administration means "Cog", so you are in the right place. Please ask the root user to fill the SSL certificate for you.

Comment actions Permalink

I have no idea what you are talking about!...

What is 'Cog'? Which root user? (cause as I said: I am the system admin already!!)
And a place where to load the certificate (which I have already created)  is also not available if not at menu 'SSL certificates'.

Please be more detailed so that I can understand!
Thank you very much.

Comment actions Permalink

Please see open "Administration" menu ("cog" is a cogwheel):

Root user is the user that created YouTrack installation. 

Comment actions Permalink

Oh, I know about that!
Please see my options menu here:

Which option do you advise me to select? Unfortunately you still don't mention it !
Cause I can only say it again: There is NO option 'Administration -> Domain Settings -> Base URL' here.
I can find 'Base URL' via 'Global Settings' ONLY!! But then I cannot find any fields/way to insert a certificate here!!
And unfortunately you still didn't describe in detail where I can find this !!

So you may not understand my real question/problem yet. Please read again my previous request!
Thank you very much!

Comment actions Permalink


Sorry for the misleading, these instructions are for InCloud instances.

Would you mind reproducing the error shown on your first screenshot ("Service is not accessible from your browser by given URL") and share all server logs with us? I'd recommend submitting a support request ( in order to avoid disclosing any sensitive data. 

Thank you!

Comment actions Permalink

Ohh, I am glad. I already thought...

So you admit that menu option 'Domain Settings' does not exist in my version!...
But then how can be changed from http:// to https:// in this version?? It is not as comfortable as the InCloud version?
No later change? Only via the install process??
Why so limited?...

So then, how can I arrange it that during start of Youtrack the setup window is displayed again, without deleting the current configuration??...

To your question this is the screenshot of the problem I once got:

Is this enough for you? Or do you still need the server logs as well ?...

Do you mean the big log file of the Youtrack start? Or even the one of the screenshot's setup process only?....
Cause these specific logs to reproduce would make some expense for me! Is that really necessary? I cannot see an unusual process here!?...

Thank you for your assistance!

Comment actions Permalink

Actually, there is a possibility to switch to https via command line, but I suppose this will also fail, so let's try to find out the root cause.

Could you please share your certificate and logs (here is a guide on how to find them: 


Please sign in to leave a comment.