Testing instance on alternate https port

Hi, I'm trying to setup a second youtrack instance for testing. For this I set my docker-compose to map ports as follows

- "8008:8080"
- "44300:8443"

(The original instance maps "8443:8443" and works fine with https)

I tried two different configs on the HTTPS setup page:

  1. Base URL: https://my.server.com:44300
    Application Listen Port: 8443
    Error: Port in base URL doesn't match with secure listen port
  2. Base URL: https://my.server.com:44300
    Application Listen Port: 44300
    Error: The service isn't accessible from your browser at this URL. Verify that the listen port 44300 was properly exposed or published on startup of the Docker container

I'm sure 44300 should be accessible because when I map "44300:8080" I can access youtrack via http.

What am I doing wrong?

1 comment
Official comment


I'm Sergey from the Youtrack team.

I'm sorry for the delayed reply. Generally, if you'd like to get in touch with our support team directly for a quick answer to your question, please fill in a direct request at https://youtrack-support.jetbrains.com/hc/en-us/requests/new We'll be happy to help.

Now regarding your question, you've not done anything wrong.

Base URL: https://my.server.com:44300
Application Listen Port: 8443

This approach is correct, yet there's a known issue when setting up TLS in Docker when mapped ports differ. As of now, the web UI has a validation check for the base URL and listen port when setting up TLS. It works for all the cases except when your mapped host and Docker ports are different, e.g., "44300:8443". 

The solution is to map the same ports: 44300:44300, then you'll be able to enter the same port in both base URL and listen port fields. Alternatively, you can set up TLS via the command line.

Please sign in to leave a comment.