Projects leads receive no notifications on issue creation

Answered

Hi

I cannot get notifications for new issues, even though I'm the project leader. Other notifications work fine, like if I'm assigned to the issue or have commented on an issue. Notifications also works fine when issues are created for projects with other project leads than me.

From the notifications.log file I get this information when an issue ("sbw-79" in this case) is created:

28 Apr 2017 10:30:04,469 INFO [fyingAnalyzerJobProcessor] [DG_AJ:sbw-79:7516#7516:25-41] started
28 Apr 2017 10:30:04,500 INFO [fyingAnalyzerJobProcessor] [DG_AJ:sbw-79:7516#7516:25-41] finished
28 Apr 2017 10:30:04,500 INFO [fyingAnalyzerJobProcessor] [DG_AJ:sbw-79:7516#7516:25-41] created [UP_IS:7516#7516:sbw-79:25-41#25-0]
28 Apr 2017 10:30:04,508 INFO [NotificationJobProcessor ] [UP_IS:7516#7516:sbw-79:25-41#25-0] -X [any:admin:root] notifications channels are disabled

It seems that Youtrack tries to notify the root user instead of me, which explains why it doesn't send any email. But why won't it try to send to my user? 

Regards

Tomas

 

 

5 comments
Comment actions Permalink
Official comment

Hello Tomas, thank you for reaching out and sorry for the delay.

Could you please attach screenshots:

1) Projects > your project > Edit project

2) Your profile > Notifications settings > Subscriptions section.

You can paste them here or you can send them to youtrack-feedback@jetbrains.com

Thank you!

Comment actions Permalink

Hi Liubov

 

I've sent you the two screenshots you requested. I couldn't find an issue number anywhere so instead I included the full issue title in the message subject.

 

Regards

/Tomas

0
Comment actions Permalink

Tomas, thank you very much for those screenshots.
It looks like you've unsubscribed from the saved search that would send you notifications from this project. You need to re-subscribe to this search manually: click 'Add subscription', select the 'Unassigned in sbw' search from the list and subscribe to issue creation for this search.
Please let me know if I can help you any further.

0
Comment actions Permalink

When I first noticed that I did not get any emails on new issues I created a new saved search – just as you described – and subscribed to new issues. That did nothing. The second screenshot I sent also shows the "Unassigned in TEST"-subscription. I added that just to troubleshoot this issue, but that didn't work either. Then I read somewhere (I cannot locate the source) that project leads should receive notifications regardless of the subscription settings. Maybe that was incorrect or I misinterpreted it?

Just as I wrote this I tested to switch project lead to another user and then back to me, and then the notifications started working(!) As far as I can see they look identical to the manually added subscriptions (which I confirmed did not work). No matter, the important thing is that it's working again. Thanks for your help.

0
Comment actions Permalink

Tomas, thanks for getting back to me. When you create a project, its Project Lead gets subscribed to a 'Unassigned in <project>' saved search, and you as a project lead can unsubscribe from this search as from any other search.

0

Please sign in to leave a comment.