YouTrack and nginx as reverse proxy

 

Hi!

 

I'm using the YouTrack ZIP which is installed and running fine behind nginx as reverse proxy.

Setup SSL which also works as expected with a browser.

 

However, trying to use the JetBrains plugin within PHPStorm for YouTrack, using SSL, connection is always timed out or failed.

The certificate is not self signed and is a chain certificate, issued by let's encrypt.

I tried adding the certificate as trusted certificate to PHPStorm as well, but still connection time out.

 

If I disable SSL on nginx, it works like a charm and connects within 1 second though I would prefer to use SSL.

 

3 comments
Comment actions Permalink

Hi Pieter, I've created a ticket for this issue in our support system.

0
Comment actions Permalink

Hello Pieter,

 

1. Please enable debug logging in PhpStorm as described in https://github.com/jk1/youtrack-idea-plugin

2. Reproduce the problem

3. And attach the logs from PhpStorm here

 

Thanks in advance.

0
Comment actions Permalink

Hi Liubov Dievskaia and Eugenbox,

 

Thanks for the very fast replies!

as per Eugenbox's instructions, here's the log file:

https://netabuse.net/idea.log 

 

Thanks for helping out!

 

 

 

0

Please sign in to leave a comment.