Issue when attempting to access via external URL

I have a Hub and YouTrack installation on a personal server. Port Forwarding is set up correctly and working.

The Hub installation is accessible via external URL (hub.domain.com masked WebHop to www.domain.com:8080), as well as internal (localhost.home:8080). In order to do this I had to add the external domain (www.domain.com:8080) into the Redirect URIs under Hub > Services > Hub.

The YouTrack installation is only accessible via internal URL (localhost.home:8081), even with a correctly configured external URL (projects.domain.com masked WebHop to www.domain.com:8081). The error I am receiving seems to be related to CORS, but I have tried enabling "Allow all origins" as well as white-listing the external domain. Neither of these have had any effect. I have added the external domain (www.domain.com:8081) to the Redirect URIs in Hub > Services > YouTrack, but this also has not had any effect.

Is there something I am missing here? Does the way YouTrack work differ from the way Hub works in this regard? Is there a way I can get YouTrack to be accessible from outside of my local network?

2 comments
Comment actions Permalink

Hello! Could you please write us to youtrack-feedback@jetbrains.com and provide the following information:

1) Please send us the full /conf folder from your Hub instance

2) Also please send the full /logs folder from your Hub instance.

3) In addition, send screenshots from these pages:

Hub > Services > Hub

Hub > Services > YouTrack

4) Let us know the build numbers of YouTrack and Hub that you're using.

5) What do you see when you open http://www.domain.com:8081/ ?

 

Thanks!

0
Comment actions Permalink

To give an update:

The issue appears to be related to using cloaking on WebHops (which I believe would be desirable in many cases) to hide the redirect, although I was still having issues even after disabling cloaking.

After much back and forth, I did away with the WebHops entirely and used nginx's proxy_pass directives instead, using a completely clean YouTrack installation to make sure that there were no configuration 'hold-overs' from all the troubleshooting. After adding the external url (http://projects.domain.com/oauth) into the Redirect URIs field to enable the hub, it appears to be working.

This may not be an ideal solution for some users (I have not looked into every possible consequence of doing things this way), but it appears to work at least.

0

Please sign in to leave a comment.