Youtrack won't let users do anything after migration from InCloud to Standalone

Hello,

 

I used Youtrack InCloud and then moved the DB to the standalone version. It didn't work too well but at the end it did; I see all the users and the issues. However, regular users cannot see any project or board, when trying a direct link they see this:

403: Woah, you can't touch this!
Unfortunately, you are not allowed to access the page you've requested. It seems you don't have sufficient permissions.

Their Issues page gives this:

You have no permissions to view this page
Try to log in again, go to issues page (logged in as '%USERNAME%'), or contact your system administrator.

 

Their dashboard is blank.

Myself as a root user can login and see anything. They can login and logout without any problem.

I have ZIP installation on Linux.

Any suggestions?..

 

thanks

5 comments
Comment actions Permalink

Looks like permissions do not work. If I give a user a role of System Admin to the projects, he can work; otherwise, he cannot.

0
Comment actions Permalink

Seems I finally found it. All the permissions were removed while migrating.

0
Comment actions Permalink

Hello Jinn, I'm sorry for the delayed response.

Do you need any assistance at the moment? If yes, please describe how you migrated your database (in steps) + provide the full logs of your instance as per p.1 here: https://youtrack-support.jetbrains.com/hc/en-us/articles/206546369-When-we-ask-you-to-provide-additional-details-logs-database-HAR-etc-

Thank you.

0
Comment actions Permalink

Hi,

thanks for the response. Currently everything works fine, after I went permission by permission and fixed each action manually. Nothing was allowed for any role except for the system admin.

However, I must say migrating from InCloud to standalone was a real nightmare and took me hours. I tried both approaches: tried to upgrade the installation without using it, and also tried python scripts. None worked fully; the guide for the upgrade is misleading (wrong), and python scripts fails with errors.

Probably  you'd like to look into this..

If  I can be of any help I'll be glad to. I managed to use the upgrade approach to download all my users, projects, boards, fields and about half of the issues; the rest I just copied manually. My InCloud copy is empty now.

Please let me know if my logs can help you.

0
Comment actions Permalink

Jinn, thanks for the update.

Could you please point us to the places in the documentation that you've found confusing?

The guide on migrating from cloud to standalone is here: https://www.jetbrains.com/help/youtrack/incloud/Migrate-from-InCloud-to-Standalone.html

Thank you very much for the help!

0

Please sign in to leave a comment.