New sprints won't show in agile board view

Answered

Guys/Girls,

 

Bare with me because I'm new to all of this. Originally we were able to create issues on the Issues tab and agile boards and have the New sprints show when selected. Now, that our head of engineering left. For some reason when we create an issue not from the agile board we can't see it in the latest sprint....of course but the current sprint does not show in the dropdown when im creating a bug or something. I have to make it directly on that agile board because all cards are on the current sprint.

 

Hope that made sense. What am I doing wrong?

18 comments
Comment actions Permalink

Hello, could you please show us some screenshots illustrating the problem?

Also please attach screenshots with the board settings, tabs 'General' and 'Columns and Rows'.

Are you using a cloud YouTrack instance? If so, please tell us the name (URL) of the instance. If it's a standalone one, then let us know the build number (you can check it in the lower-left corner of any YouTrack page).

Thank you!

0
Comment actions Permalink

Thank you for the clarification.

It looks like you're using a cloud instance, what is the URL?

Also I would still need screenshots of the board settings (two first tabs), you can open them by clicking the cog icon in the upper-right corner of your board.

0
Comment actions Permalink

I need to get admin rights. Working on that now.

0
Comment actions Permalink

also another thing I noticed if i add a card on the issues page or make a subtask of it from there its getting assigned to a different board. If I can figure out that I think we solved the problem bc i found out they are getting added to an older board and not the new one. I know i can add the board at the bottom right when i create a card but how can i get it to automatically pick the correct board.

0
Comment actions Permalink

As far as we can see from the board configuration, he field 'Sprints' is not currently linked to your board. If you'd like to be link 'Sprints' values to board sprints, you need to select the third option in the 'Board Behaviour' section of the board settings.

Please take a look at this guide, it explains how different boards behave depending on the settings: https://www.jetbrains.com/help/youtrack/incloud/Sprint-Options.html#agile-board-with-sprints

If you'd like to assign an issue to your board with its current configuration, you need to apply command to it: `add Board <board_name> <sprint name>`.

> if i add a card on the issues page or make a subtask of it from there its getting assigned to a different board

Please check the settings of this second board. If you have any questions, please attach the screenshots of this second board settings.

0
Comment actions Permalink

Thank you so much. We are off today. I will try that as soon as possible. Thank you for your time.

0
Comment actions Permalink

When i chose the third option it completely took everything off our boards! How do we fix this? Is their a support number?

0
Comment actions Permalink

This is expected if you selected the third option because this option transfers your board into automatic mode. There should have been a confirmation popup when you changed the board behavior explaining the mechanism of the mode you're selecting and possible consequences.

Unfortunately, it's not possible to revert this action, we can only suggest to find the relevant issues and add them to the board manually.

Please refer to the documentation on different board modes here: https://www.jetbrains.com/help/youtrack/incloud/Sprint-Options.html#agile-board-with-sprints

Let us know if we can help you any further. Unfortunately, we don't provide phone support, but if you need an urgent reply from us, you can always submit a support request or write us to youtrack-feedback@jetbrains.com

0
Comment actions Permalink

So they were just moved to unscheduled correctly? We moved the swimlanes over but it didnt carry the cards. So we just have to manually assign each correct

0
Comment actions Permalink

alright so we fixed that but now when we create subtasks or edit the subtask of on that card it moves it to uncategorized. why cant it just keep the same placement

0
Comment actions Permalink

Please share the current settings of your board, tabs 'General' and 'Columns and Rows'.

Thanks!

0
Comment actions Permalink

Thank you for the screenshots.

Since swimlanes on your board are identified as issues, then in each swimlane you can only view the direct subtasks of the swimlane issue. If there are subtasks of those subtasks (three-level hierarchy), they are not connected directly to any swimlane, that's why they get into Uncategorized.

0
Comment actions Permalink

Last question, what should they be set to in order for those cards not to be set to uncategorized.

0
Comment actions Permalink

With your current configuration, cards should be direct subtasks of the swimlane issues to be displayed in the swimlanes (not in Uncategorized).

If you change the swimlanes to be identified by values from some custom field, then each swimlane will display cards that have this swimlane value in the selected custom field.

Please learn more about swimlanes configuration here: https://www.jetbrains.com/help/youtrack/incloud/Agile-Board-Settings.html#Columns-and-Rows

0

Please sign in to leave a comment.