Hide empty Swimlanes in Agile Board

Hello together,
I have some question regarding Agile Board setup. We are using the Agile Board now for some time allready with a setup where we identified the swimlanes by issues of the type "feature". Now we want to change that setting to use the subsystem field of an issue instead. However it would be nice to hide all swimlanes which have no issues applied, so that only subsystems are shown with open issues in a sprint.
I know that would prevent me from using some features like drag and drop for changing the subsystem type or using the plus icon to directly create an issue in the swimlane.
But with a lot of subsystems the list of swimlanes is far to long and as I said, i would prefer just to see, what subsystem is affected for the sprint.

7 comments
Comment actions Permalink

Hi Marco Da Cuncha,

Thank you for your patience!
It's possible to collapse swimlanes by clicking "-" in front of each swimlane. Did you mean it's the option for you?
Also, you can set query in the board's settings, like:
has: parent for
which means only parent tasks which have Parent for link should be shown.

Let me know if need any further assistance.

1
Comment actions Permalink

Hello Andrey,
unfortunatly this isn't what I'am looking for. The suggested behavior I know allready. But my goal would be not using a ticket for the swimlanes at all. The swimlane should be represented by the project-sub-system selected for an issue. The problem is that sub-systems defined in a project are not getting hidden when there is no issue in the sprint.

0
Comment actions Permalink

This is a pity that you can't use "has: parent for" in auto board query

 

upd: not true, you can

0
Comment actions Permalink

Andrey, actually you should be able to use this in the query: `has: {Parent for}`

1
Comment actions Permalink

Says that board query doesn't support has operator

0
Comment actions Permalink

Andrey, could you probably attach a screenshot? Thank you.

0
Comment actions Permalink

Ok, I cant reproduce this message)

Thx, now I can use it, because I stop trying))

0

Please sign in to leave a comment.