Can't attach screenshot because of the proxy dialog

Hello!

I'm trying to use "Attach Screenshot" feature in YouTrack 2.1.2.

Plugin works ok until it starts uploading image to the server. It asks proxy url and port.

My network setup uses static ip address, i.e. my ip is: 192.168.1.22, mask: 255.255.255.0, gateway: 192.168.1.1. I tried to use gateway ip for proxy url and 80 for port but it doesn't work.

I'm also using snapengage.com service which has similar feature (java applet takes screenshot and sends it away) and it works fine without asking any proxies.

Hope you can help with it.

P.S. "Attach File" works just great.

7 comments
Comment actions Permalink

Alexey, are you an administrator of the YouTrack installation? If you are, check that Base URL that was defined on settings page corresponds to actual URL of your YouTrack installation.

0
Comment actions Permalink

Yes, I am. Base url seems ok and matches with the result of "Guess Url" and domain name of the Youtrack installation.

0
Comment actions Permalink

When you press attach button, screenshot applet tries to attach an image using REST API. Please check that host/port of your YouTrack installation is not prohibited for screenshot applet by firewall.

PS. Anyway message about proxy appears when applet can't access YouTrack server for some reason.

0
Comment actions Permalink

How can I check this? I can use REST API (get issue for example) from my computer on port 80. Or should I check if this http://confluence.jetbrains.net/display/YTD2/Attach+File+to+an+Issue works for example?

0
Comment actions Permalink

Alexey,

Probably you start youtrack using jdk 1.5.

If so, you have to options to fix issue: upgrade to 1.6 or get patch attached to http://youtrack.jetbrains.net/issue/JT-7251

0
Comment actions Permalink

Vadim, I really had that problem in the past (it was in separate topic here) and upgrading to 1.6 fixed this, so it's not the case for now. Additionally I've just successfully attached screenshot from my home notebook, so it's definitely some environment checking and not jdk problem.

0
Comment actions Permalink

It seems I know possible problem. My office network setup uses squid, and google says that there are some problems with java applets and squid.

Maybe there are some known parameters in squid conf that should be disabled, does anybody know?

0

Please sign in to leave a comment.