Failed to import from YouTrack Cloud with encoding related errors

Hello, I want to move off of the cloud because of the issue http://youtrack.jetbrains.net/issue/JT-3412 – it really makes working with YouTrack inCloud for touch typist not pleasureable.

I tried to restore my on premise 10 user free installation with db backup, but failed. I can provide log if needed.

I tried youtrack2youtrack python client script and after struggling with lots of problems related to encoding managed to import project bundles, but failed to import issues with following error:

Failed to import issue [ mares-88 ].

Reason :

<item id="88" imported="false"><error fieldName="Priority" value="0">Value is un

known</error></item>

Request was :

Traceback (most recent call last):

  File "youtrack2youtrack.py", line 233, in <module>

    main()

  File "youtrack2youtrack.py", line 21, in main

    youtrack2youtrack(source_url, source_login, source_password, target_url, tar

get_login, target_password, project_ids)

  File "youtrack2youtrack.py", line 209, in youtrack2youtrack

    print target.importIssues(projectId, project.name + ' Assignees', issues)

  File "c:\Users\wzory\Downloads\youtrack-python-api-3.0.2-44\python\youtrack\co

nnection.py", line 288, in importIssues

    print issue_records[id]

  File "d:\Python27\lib\encodings\cp852.py", line 12, in encode

    return codecs.charmap_encode(input,errors,encoding_map)

UnicodeEncodeError: 'charmap' codec can't encode character u'\u2013' in position

941: character maps to <undefined>

My system is Windows 7 Pro 64-bit. I ran script with Python 2.7.2. I use Chrome to enter issues. I use polish diacritics. Also in States and Types of issues (but I've changed it import my project).

2 comments
Comment actions Permalink

Hello, Wojciech!

The good way to migrate from YouTrack InCloud -- is to restore your db from backup. Could you please provide logs for this? I've created issue about your problem: http://youtrack.jetbrains.net/issue/JT-12914 , so it would be grate if you attach your logs to that issue, instead of this discussion thread. Also, do not forget to change visibility of attached logs to youtrack-developers group.

Thank you!

0
Comment actions Permalink

Hello!

YouTrack InClod has Database Export in administration. You can download your zipped database, unpack it locally into user_home/teamsysdata and start local youtrack - it must pick up your db.

0

Please sign in to leave a comment.