YouTrack demo RootGo redirect

Hi There.

I was asked to evaluate YouTrack for my company. I installed the demo version at a windows 2008 server box.

The app works fine on localhost. However for external access:

I type <servername>:myPort
and I get redirected at http://localhost:myPort/rootGo

(external port is open from firewall). For TeamCity the demo install seems to work fine.

Is there another configuration step that I am missing here?
3 comments
I'm not positive, but if I had to guess, I'd say try going to Administration -> settings, and under System, change the base URL to the external URL you're trying to access it through.
0
Yes, you are redirected to localhost, because you base url is set to http://loclhost:port
You need to set http://externalURL:port as base URL on Administration->Settings page.
0
I would like to add the following to your answer:
When you have the configuration where your modem/router redirects port 80 to e.g. 8081 for the YouTrack Service. You should not enter the `:port` in the base-url.
It should just be: `example.com`. Because there is no actual listening to :8081.
0

Please sign in to leave a comment.