OpenId not working after reinstall

Hi,

I've installed YouTrack (not sure which version, about 2 months ago I guess), and while testing had it on localhost:93.

I've uninstalled and reinstalled, and YouTrack still seems to be finding localhost:93 from somewhere as it's using it as a callback URL from Google OpenId, even though I now have it working on the correct domain. I can't seem to administer this anywhere - I think perhaps because I set OpenId to be the only login method in my previous install?

How do I change this? Where is it stored?

I'm running v4.0.2 on Windows 2008 R2.

Thanks.
4 comments
Comment actions Permalink
It is stored in "Base URL" setting on Settings page.
To find it go to Administration -> Settings and set "Base URL" to right url for your YouTrack installation.
0
Comment actions Permalink
Hi, thanks, but my point is that I can't get to the settings page because I can't log in!

I meant where is it stored that I can modify it manually so that I can log in.
0
Comment actions Permalink
This parameter is stored in database, so it's not possible to edit it outside. But you can use start parameter -Djetbrains.youtrack.baseUrl="http://yourhost:port/<youtrack>" to set it on application start.
0
Comment actions Permalink
One more way how to get to /settings or /setUp page without restarting YouTrack
For instance if you are running YouTrack on localhost:93 you can do next

1. Go straight to login form http://localhost:93/login
  1. Login there, you'll be redirected to another URL, but don't give up
2. Go straight to http://localhost:93/setUp or http://localhost:93/settings page, change baseURL and save changes.
0

Please sign in to leave a comment.