tomcat Server crashed

Hello,

i have setup a Tomcat Server in a Virtual Machine (Windwos 2008 Server ) with youtrack WAR file (Version 4.0.3)
The Tomcat Service is installed as a Windows Service.

This will work fine, but after an undefined time the Tomcat Service is stopped without any exit code.
I found an Minidump file in the "Tomcat\bin" folder. See attached Log files. I Also added the a screenshot with tomcat settings page.

Could you help me?

Regards
Nok

hs_err_pid1480.log (21KB)
hs_err_pid4044.log (11KB)

hs_err_pid3816.log (21KB)
hs_err_pid3884.log (21KB)
tomcatSettings.png
6 comments
Comment actions Permalink
Hello, Martin!

Could you, please, attach logs from %Tomcat_HOME%\logs ?
(youtrack log, catalina.log etc)

--
Regards,
Mikhail
0
Comment actions Permalink
Hi Mikhail

yesterday on 02.10.2012 i had a crash on 8:55 am and on 10:14 am.
Beyond 10:14 i'am replaced the Tomcat7 with a Tomcat6 Version. The downgraded server crashed also on 02.10.2012 at 12:31 pm. See attached Zip file. The dump logs as i attached in my first comment did not exist any more, sorry for that.

But Since 02.10.2012 12:45pm:
i'am installed youtrack with the "*.exe" Setup file. This Version works currently fine, since yesterday.

I have no expierience with Tomcat or another Apache Webserver, but in future i will use also TeamCity Server and i will know how it works and how has to be installed or setup. For this i will setup my tomcat server manually from the scratch. Did you have any documents how describe what apache settings are important to install youtrack?


Logs.zip (2.5MB)
0
Comment actions Permalink
Oh i found under System requirements, the following description:

We recommend to start YouTrack with at least 512M of heap memory available. For best performance, set the following JVM options:
  • server -Xss2m -XX:SoftRefLRUPolicyMSPerMB=10000 -XX:+UseConcMarkSweepGC
0
Comment actions Permalink
I Compared the Youtrack Installation from the "*.exe" setup with my manual installed tomcat apache server. The Only difference i found is, that you use the JAVA JRE 1.6 and i use the JAVA JRE 1.7. Could be this a possible reason?
0
Comment actions Permalink
Sorry for delay.
Yes, It's quite possible.
Try to upgrade JRE 1.7 to the latest version or better: try to use JAVA JRE 1.6

--
Regards,
Mikhail
0
Comment actions Permalink
yes i use latest JRE 1.6 and now it works!
Thank you
0

Please sign in to leave a comment.