Spent time calculated incorretly

Time Tracking Settings:
  • days in week: 5;
  • hours in day: 8.

I created an issue yesterday noon and set the Timer field to Start.
Today in the morning a changed the Timer field to Stop.
Then i got an popup notification that spent time is 21h xxM xxS but the Spent time field got value '1w2h18m'
5 comments
Comment actions Permalink
Please check if new work item is added on 'Time Tracking' tab when timer has stopped.
If 'No' please check the user permission - it has to have got "Read Work Item", "Update Work Item" permissions.
0
Comment actions Permalink
A new item was added.
I've attached a screenshot with an illustratian of a problem. Some times it works fine though.
And else one notice - YT seems to be an hour earlier than a server time (things an the screenshot happend at 12:20 and 13:34 accordingly)
19-11-2012 13-41-29.png
0
Comment actions Permalink
YouTrack server time you can set on 'settings' page in Administration.

I see the new work item is added and the 'Spent time' value is changed to 2h14m as well.
Please clarify the problem.
0
Comment actions Permalink
The problem is hightlighted with blue lines.
My original post says that time calculates incorrectly.
As you can see on the screenshot a time gap between events is 1h14m not 2h14 as well as in prev. situation 21h xxM xxS and not 1w2h18m
0
Comment actions Permalink
I've found the problem in the "workTimer" workflow. I will fix it ASAP. Please follow JT-17552.
Thanks for feedback.
0

Please sign in to leave a comment.