Difficulty using workflow editor

Okay, since I'm not seeing an outcry about this, I assume it's just me. I'm trying to do some custom workflows, but the editor is proving to be a real PITA. Some examples of the types of things I'm running into:

  • I never know what's going to happen when I press delete or return. Delete may delete a character or an entire block, and return may go to the next line or skip down after the block I'm on.
  • I had one rule that showed syntax errors in the editor where there weren't any but still worked properly in YT, and another that showed no errors in the editor but was broken on the server.
  • I have two rules that have the same content, but one of them is mostly in red and shows the error "Warning: Type e12 was not calculated." Not a clue what that means, though.
  • I stumble with how to do basic editing. For example, I have yet to figure out how to turn an existing if-block into an if-else-block without losing code, and I can't even select text for bulk deletion.
  • Copy-and-paste is MIA, as are, apparently, features like moving a rule from one workflow to another. So, I end up spending a lot of time retyping things I've already typed elsewhere. Which sometimes works and sometimes doesn't.
  • When I stumbled on a post somewhere that documented a hidden workflow rename function, I tried it out and it worked, but when I tried to change the name back to the original, it wouldn't let me - said it wasn't a valid Java class name. Not sure why I was able to use it to begin with; maybe this is why the rename feature is still hidden.
  • Completion doesn't offer anything useful on variables.
  • At times, I simply can't type what I'm trying to type, even if I know it's correct. For example, yesterday, I had an uninitialized variable named user, and I was trying to type "user = issue.Assignee;", but I couldn't get past the = character without either completion getting in the way and then removing what I'd typed when it didn't offer what I needed, or the next character simply being auto-deleted right after typing it. It's almost like the editor expects me to type content in the form of syntactically valid blocks rather than individual characters and words that eventually combine into syntactically valid blocks.

I could go on and on, but I think that's enough to make my point. Obviously, the editor is a fairly low-level affair, but wow, it sure is a frustrating experience. But then, I've not found even a single similar complaint, so I can't help but think that something simply is not right on my end. Any ideas or experiences that others may share? I think workflows are one of YouTrack's greatest features, so I really want to take full advantage of them.

FWIW, I'm running the editor on Mac OS X 10.7.5 with Java 1.6.0_37. (I actually have the latest Java 1.7 from Oracle installed, but I can't figure out how to get applications like PhpStorm or the YouTrack workflow editor to use it versus Apple's 1.6 version.)
3 comments
Comment actions Permalink
Hi Bob,

I assume that you have to update your Java HOME variable with the new path to Java 1.7 on your machine. What type of installation of YouTrack do you use (jar, as a Win service)? If you install YouTrack as a jar, point path to Java 1.7 during installation on your Mac.

As I've said in thread http://forum.jetbrains.com/thread/YouTrack-836 "Workflow editor" is our fast changing tool and we realy apreciate all feedbacks! But unfortunately, I should say that fixes based on your points won't be fixed in current "Workflow editor" . We have a task http://youtrack.jetbrains.com/issue/JT-17984 about our new in-browser editor with similar functionality. I add your points to this task, so all of them will be taken into account. New in-browser editor will be included in our next big release. You are welcome to leave comments and watch for updates.

Thank you for your review and feedback once again.


Don't hesitate to contact us, I believe we could help you with your own workflow implementation.
0
Comment actions Permalink
Hi Bob,

As I've mentioned at this thread http://forum.jetbrains.com/thread/YouTrack-836 , you are welcome to read our resources. I repeat them here in this thread once again.
Please take a look at these resources for more experience with Workflow editor:

This is our YouTrack blog http://blog.jetbrains.com/youtrack/
This is the MPS blog, as Workflow editor is customized MPS http://blogs.jetbrains.com/mps/
This is the blog of YouTrack evangelist Hadi Hariri http://hadihariri.com/


Thank you.
0
Comment actions Permalink

More then three years on and we're still stuck with that abomination. 

The "in browser editor" ticket has no activity other than accumulating votes and the occasional duplicate ticket. The "next big release" as you called it has come and gone two times over but nothing has changed.

Can you give an update with a reliable timeframe when we can expect this feature to land?

0

Please sign in to leave a comment.