Time Tracking, via command

Hi everyone!

I have a question regarding the command-line on an issue, and the possibility to add "work".
When I add work time via the command, i.e "work Today 1h Installation", I can see that the "Time Tracking" tab and the spent time-field is updated. But when I review a Time Report that includes my issue the row is not included. It's missing from the Time Report.

Is there any more command i need to run to get the time to show up on my Reports?

/Henrik
8 comments
Comment actions Permalink
Hi Henrik,
Time (and matrix) reports don't get recalculated automatically, so you need to manually press 'recalculate' button. Please also consider the following comment: http://youtrack.jetbrains.com/issue/JT-18303#comment=27-435735

Regards,
  Alexander
0
Comment actions Permalink
Thank's for your replay Alexander. But even if I hit the "Recalculate now"-link at the Time Report, the time will not appear.
I append a screen show that illustrates my point of view.

work.png
0
Comment actions Permalink
Henrik,
The query that's blured on the screenshot is quite important. Could you please either email to youtrack-feedback@jetbrains.com or just create a report with empty query?
0
Comment actions Permalink
I did a new test. Here is the uncensored version. :)
Skärmavbild 2013-02-27 kl. 18.20.36.png
0
Comment actions Permalink
I want to make sure it's not related to some timezone issue. Could you please increase the interval for the report? Say, from 26 to 28 Feb.
0
Comment actions Permalink
I have increased the interval. Here is a screenshot.
Skärmavbild 2013-02-27 kl. 20.37.52.png

Skärmavbild 2013-02-27 kl. 20.40.42.png


It seems like the date is added to the previous day when calculating the report.
0
Comment actions Permalink
Is there any setting that i can set, to correct this timezone-issue?
0
Comment actions Permalink
Henrik,
I can not suggest any workaround yet. Will get back to you later this week.
0

Please sign in to leave a comment.