Is there a way to specify context for standalone

I've installed standalone JAR version of YouTrack (5.0.3) and want to make it accessable via lighttpd under subdirectory, something like dev.mycompany.com/youtrack

Then i try to reach youtrack via lighttpd proxy a got «This page not found» error and the following lines in wrapper.log:

INFO   | jvm 1    | 2013/10/24 10:33:19 | 10:33:19,445 INFO  [MainServlet    ] [uest: /youtrack] [internal@192.168.5.111] Start processing request /youtrack
INFO   | jvm 1    | 2013/10/24 10:33:19 | 10:33:19,445 ERROR [ResponseFactory] [uest: /youtrack] [internal@192.168.5.111] No response action for uri: /youtrack
INFO   | jvm 1    | 2013/10/24 10:33:19 | 10:33:19,445 ERROR [MainServlet    ] [uest: /youtrack] [internal@192.168.5.111] No response action for uri: /youtrack
INFO   | jvm 1    | 2013/10/24 10:33:19 | 10:33:19,447 INFO  [MainServlet    ] [uest: /NotFound] [internal@192.168.5.111] Start processing request /NotFound
INFO   | jvm 1    | 2013/10/24 10:33:19 | 10:33:19,448 INFO  [ResourceBundle ] [uest: /NotFound] [internal@192.168.5.111] Create new resource budle [text/css]
INFO   | jvm 1    | 2013/10/24 10:33:19 | 10:33:19,453 INFO  [ResourceBundle ] [uest: /NotFound] [internal@192.168.5.111] Create new resource budle [text/javascript]
INFO   | jvm 1    | 2013/10/24 10:33:19 | 10:33:19,468 INFO  [MainServlet    ] [uest: /NotFound] [internal@192.168.5.111] Finish processing request /NotFound in 22ms
INFO   | jvm 1    | 2013/10/24 10:33:19 | 10:33:19,468 INFO  [MainServlet    ] [uest: /NotFound] [] Finish processing request /youtrack in 23ms


Is there a way to change context of youtrack application in the standalone JAR. I've found standalone.xml in JAR but it does not contains context declaration.

I tried to change mapping to MainServlet in web.xml without luck.

Setting Base URL does not help either.
1 comment
Comment actions Permalink
Hello Igor,

Base URL setting under Administration is the path for the database only.
Please, take a look at the answer under similar thread.

Thank you.
0

Please sign in to leave a comment.