"Can be empty" checkbox greyed out

I have several projects that share a field with different bundles attached to it.  I'd like to uncheck the "can be empty" checkbox but in all but one project, it's greyed out.
8 comments
Comment actions Permalink
I think you have to specify it when you attach the custom field to a project.  So you might try detaching and reattaching.

Just started using YT yesterday though, so I could be wrong :)
0
Comment actions Permalink
That did work...  you lose the the values of that field for all tickets where it's set but in some cases, that could be OK.
0
Comment actions Permalink
Glad to hear it!  I wish someone from JetBrains actually monitored these forums... then maybe someone could answer my questions.  :)
0
Comment actions Permalink
Often they do and are fairly responsive. Maybe they're busy getting 5.1.1 out the door :)  You know you always have the option to file a bug on the Jetbrains youtrack :)  http://youtrack.jetbrains.com/dashboard
0
Comment actions Permalink
Sorry for not replying sooner.

To make 'Can be empty' checkbox enabled you have to choose some not null 'default value' for this field in the given project and ensure that all issues in the project have not empty value.
0
Comment actions Permalink
Thanks - we'll try this.
0
Comment actions Permalink
In some cases, what I really want is for there to NOT be a default value and at the same time, force the user to fill in the field.  Would I need a workflow for this?  How would I do it?
0

Please sign in to leave a comment.