Mailbox Integration issue

I don't seem to be able to make Mailbox Integration work.

I've added a mailbox, connection test succeeded.
Then added a rule, to extract mail and put them in a project.
Everything seems fine, I see no errors, but there's no issues created from emails. I've tried using both POP3S and IMAPS.

I've checked the YouTrack log files, there's no error, and it seems that YouTrack doesn't "see" any emails in the mailbox. Here's the log:

09:00:04,158 INFO  [MailboxImpl    ] [tzJobProcessor0] [] Start mail fetching
09:00:04,220 INFO  [MailboxImpl    ] [tzJobProcessor0] [] Resolving folder INBOX
09:00:04,236 INFO  [MailboxImpl    ] [tzJobProcessor0] [] Processing folder INBOX...
09:00:04,236 INFO  [MailboxImpl    ] [tzJobProcessor0] [] Processed 0 messages from INBOX
09:00:04,251 INFO  [MailboxImpl    ] [tzJobProcessor0] [] Finished mail fetching

But I've check using both WebMail and Outlook that there are multiple emails in the inbox.
I'm not sure what I'm doing wrong.
Any help would be very much appreciated.
5 comments
Comment actions Permalink
Just to note: I've tried restarting YouTrack with clean "logs" folder, and looked through them for any errors. There's only one that seems unrelated (Jabber authentication).
0
Comment actions Permalink
I just figured that it works for emails send from an external mail server (like Gmail) do work. But emails sent from my web server won't be picked. Also, the email created by Outlook when adding the account (Microsoft Outlook Test Message) is not processed. In the Mail Rule, the "to" address is empty, I've unchecked the "Ignore auto replies" and no other filters are applied.
0
Comment actions Permalink

I have exactly the same problem. Emails send from my own web server to an email on the same server are ignored and does not get integrated.

I just upgraded to the current version.

This Problem exists since I am using youtrack ~3 years. And I am quite surprised that there is no solution till now, is it?

0
Comment actions Permalink

Michael, could you please send us screenshots of your mailbox integration settings (all of them, including all rules with all tabs expanded) + an example of a message that doesn't get fetched (in EML format if possible)?

You can send these files to youtrack-feedback@jetbrains.com for our investigation. Thank you!

0
Comment actions Permalink

I finally found the reason and added that info ona n other thread.

Our mailserver does not add the optional header message-id. The mails not having this header does not get imported (IMAP and POP3). I changed the mailserver setting to always add this header. Since this change all emails got imported.

I also noticed that if the reply-to header is missing. Emails will be imported but not deleted (if the delete option is enabled) in the mailbox at least with IMAP and if the reply-to is used during the import(did not test POP3 here).

0

Please sign in to leave a comment.