Cannot restore my database, all issues appear to be lost

I used YouTrack on my home server to organize my tasks. I liked it very much, so I decided to move the database to my company's server to replace our old issue tracking system. I created a backup and restored it on the company's server as described here:

However, when I started YouTrack, there was no sign of my project and my issues. Youtrack started as if it was a clean installation and told me I needed to create a project and start creating issues.

After many hours of frustration I have still not managed to run the database on my company's server.

Problem is, with all the experimenting, I screwed up my installation or database on my home server. I don't know what I did, but at some point I started getting the following message:

You have no permissions to view this page
Try to relogin, go to issues page (logged in as 'root'), or contact your system administrator.

When I go to issues page, there are no issues there. The user accounts are there, but all the issues are gone.

Now I'll be happy if I just find a way to restore the situation as it was this morning. I have the backups and I have the content of the data directory (C:\ProgramData\JetBrains\YouTrack\data).

I also tried a clean installation of YouTrack on a virtual machine and I copied on it the content of "C:\ProgramData\JetBrains\YouTrack\data".

Same thing: user accounts are shown but the issues are not. Also, when I go to the "Projects" page, there is a checkbox "Show archived projects". When I click on it, the name of the project is shown and it is even shown that this project has 116 issues.
But I can't "activate" them.

Can somebody help me? I don't have experience administering YouTrack and I am maybe missing something obvious.
Comment actions Permalink

I had exactly the same problem.

In my case the problem was that the permissions for the roles in my youtrack service were wrong: none of the roles had any permissions at all.

To check if you have the same problem go to Administration, ACCCES MAMAGEMENTE, Roles. Open one of the roles to see the details, and choose the YouTrack permissions. If the role has no permissions, you simply have to press the "Reset to default..." button and your problem will be gone.

I think the documentation for restoring the data from an instance of Youtrack into another, newly installed, instance should be improved. In my case, I had a local copy of youtrack to play wth it, and import issues from an Excel file. When I was satisified with my local instance, I needed to move the data to another instance in a publicly accesible server, and I had to guess what to do with the backup file. And I found all kind of problems, until it finally worked. Quite frustrating.

Comment actions Permalink

Hello, did you use this guide for restoring your database from a backup?

Could you probably point out which parts were vague or just not helpful?
Thank you very much.

Comment actions Permalink

Either I didn't follow the guide on the provided link, or the restore explanation of the restore procedure has changed (although I think I did it after february 23rd, which appears as the last change date on that page)

I installed the .msi package and manually copied part of the folders in the backup zip to the newly installed application folders (because the structure of the folders in the zip backup and the application is quite different). I completely missed the "upgrade" part.

Unfortunately now I have some problems because the database, or the config files are inconsistent, for example:

  • if I integrate youtrack to gitlab, te created web hooks points to the old youtrack url, and not to the current one (If I correct the url by hand it does work)
  • the CVS integration shows an error stating that there are more than one user with the email address used in the CVS

When I check this configuration through youtrack web, everything is fine. But in practive there must be something wrong in youtrack databases.

Is there a way to check for the content of the databases or the config files to solve these problems? I do know it's my fault  :(




Comment actions Permalink

I'm sorry for the delay. Is it possible for you to send an email to our support ( and provide us with screenshots illustrating your issues?  Please also provide descriptions of the steps that lead to those errors.

Thank you!

Comment actions Permalink

I have solved all the problems by taking these two steps:

1. backing up and "upgrading" form the backup. This partially solved the problems, for example the server url in the web hooks when integrating with gitlab was correct after taking this step.

2. I had to dive a lot in google until I found someone speaking about the '/ring' url. I logged in to this url, and, after 2 or 3 iterations of clicking all the "fix this problem" buttons the problems with duplicated users and groups, wrong permissions, and things like that, also dissapeared. I say 2 or 3 iterations, because some of the buttons failed to "fix the problems" the first time, but worked the second or third time I clicked the button. I suppose tha's because fixing some problems depended on fixing other problems before.

So, I think, you can close this issue, but not before including, or making easier to find help about '/ring' url. Something that explains that if you have problems with duplicated or dissapeared users, groups, permissions... they can probably be solved with the "magic fix this problem" buttons found on the '/ring' url.

Thnak you!

Comment actions Permalink

It looks like there was Hub integration broken on your instance. You can access this /ring page by clicking Administration > Hub Integration in the UI.

More information about this integration you can find here:

Just FYI: if there are some issues with Hub Integration found by the diagnostics, you need to click the 'Fix' buttons starting from the bottom to the top, this way the problems will be fixed correctly.

Please let us know if you have any further questions for us. Thanks!


Please sign in to leave a comment.