Issues running both YouTrack and IceScrum

Hi all,

We are having a compatibility problems of two Java servlets running in Tomcat. One of them is Youtrack and the other Icescrum. We do not have problems when launching, for example, Icescrum and TeamCity or any other application, but once we launch both Youtrack and Icescrum Tomcat becomes unresponsive. Tomcat service cannot be restarted and the only way to relaunch it is killing the process.

We did not find anything interesting in the logs. Stderr shows:

Mar 26, 2012 12:41:16 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8080"]
Mar 26, 2012 12:41:17 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8443"]
Mar 26, 2012 12:41:17 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["ajp-bio-8009"]
Mar 26, 2012 12:41:17 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 26120 ms
Exception in thread "init servlet" Exception in thread "http-bio-8443-exec-3" Exception in thread "Timer-0"

We tried increasing the JVM memory but it did not work

Catalina log does not show any errors:

mar 26, 2012 12:40:50 PM org.apache.catalina.core.StandardEngine startInternal
Información: Starting Servlet Engine: Apache Tomcat/7.0.26
mar 26, 2012 12:40:50 PM org.apache.catalina.startup.HostConfig deployWAR
Información: Despliegue del archivo C:\Archivos de programa\Apache Software Foundation\Tomcat 7.0\webapps\icescrum.war de la aplicación web
Mar 26, 2012 12:41:16 PM org.apache.catalina.startup.HostConfig deployWAR
INFO: Despliegue del archivo C:\Archivos de programa\Apache Software Foundation\Tomcat 7.0\webapps\TeamCity-7.0.1.war de la aplicación web
Mar 26, 2012 12:41:16 PM org.apache.catalina.startup.HostConfig deployWAR
INFO: Despliegue del archivo C:\Archivos de programa\Apache Software Foundation\Tomcat 7.0\webapps\youtrack.war de la aplicación web
Mar 26, 2012 12:41:16 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Despliegue del directorio C:\Archivos de programa\Apache Software Foundation\Tomcat 7.0\webapps\docs de la aplicación web
Mar 26, 2012 12:41:16 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Despliegue del directorio C:\Archivos de programa\Apache Software Foundation\Tomcat 7.0\webapps\host-manager de la aplicación web
Mar 26, 2012 12:41:16 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Despliegue del directorio C:\Archivos de programa\Apache Software Foundation\Tomcat 7.0\webapps\manager de la aplicación web
Mar 26, 2012 12:41:16 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Despliegue del directorio C:\Archivos de programa\Apache Software Foundation\Tomcat 7.0\webapps\ROOT de la aplicación web
Mar 26, 2012 12:41:16 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8080"]
Mar 26, 2012 12:41:17 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8443"]
Mar 26, 2012 12:41:17 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["ajp-bio-8009"]
Mar 26, 2012 12:41:17 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 26120 ms

We are running the latest version of Tomcat, together with latest versions of Youtrack and Icescrum .war in a VMWare with Windows 2003 Server 64 bits.

Any help would be greatly appreciated.

Thanks folks!

2 comments
Comment actions Permalink

Hello,

I'll try to investigate it.

Could you tell me what exact versions of productis do you use?

Are there any manual configurations of Tomcat made?

--

Sergey Andreev

QA Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

Hello Sergey,

Versions of products:

  • Tomcat - 7.0.26
  • Youtrack - 3.2.2
  • Icescrum - R4#4

Tomcat has been configured to work with https:

    <Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true"
               maxThreads="150" scheme="https" secure="true"
               clientAuth="false" sslProtocol="TLS"
           keystoreFile="c:/Keystore/.keystore" keystorePass=********/>


Also it has been configured to allow authentication based in Active Directory

      <Realm className="org.apache.catalina.realm.JNDIRealm"
            connectionURL="ldap://localhost:389"
              connectionName="MW\ldapinfo"
           connectionPassword=**********
              userBase="OU=Usuarios,OU=PL,DC=mw,DC=com"
           userSubtree="true"
            userSearch="(sAMAccountName={0})"
             userRoleName="memberOf"
          roleSearch="(member={0})"
         roleName="cn"
         roleSubtree="true"
         roleBase="OU=Grupos,OU=PL,DC=mw,DC=com"/>

Thanks.

0

Please sign in to leave a comment.