Failure on restore in 3.2.3

THis happens both on tomcat and glassfish. the initial upgrade to 3.2.3 seemed to kill the DB so I tryied restoring. This is using an alternate data directory. Due to company policy I have no access to the default DB diredtory.

I have gone so far as to start with a clean install and a blank database which woks fine in the alternate directory. once I unpack the backup this is what I get.

Any help would be great I have spent all day on this.

I have tried two backups and both

give the following error

17 Apr 2012 21:15:19,269 INFO  [Refactoring                   ] [init servlet                                      ] Apply refactoring: jetbrains.charisma.refactoring.RefactoringRebuildUniqueIndexes
17 Apr 2012 21:15:19,331 INFO  [TransientSessionImpl          ] [init servlet                                      ] Catch exception in flush: Failed to delete, operation unsuccessful
17 Apr 2012 21:15:19,331 ERROR [ServletImpl                   ] [init servlet                                      ] Can't init servlet
jetbrains.exodus.database.impl.OperationFailureException: Failed to delete, operation unsuccessful
at jetbrains.exodus.database.impl.Table.checkStatus(Table.java:17)
at jetbrains.exodus.database.impl.PropertiesTable.delete(PropertiesTable.java:128)
at jetbrains.exodus.database.PersistentEntityStoreImpl.clearProperties(PersistentEntityStoreImpl.java:526)
at jetbrains.exodus.database.PersistentEntityStoreImpl.deleteEntity(PersistentEntityStoreImpl.java:1020)
at jetbrains.exodus.database.PersistentEntity.delete(PersistentEntity.java:139)
at com.jetbrains.teamsys.dnq.database.AbstractTransientEntity.deleteInternal(AbstractTransientEntity.java:84)
at com.jetbrains.teamsys.dnq.database.TransientChangesTrackerImpl$7.run(TransientChangesTrackerImpl.java:453)
at com.jetbrains.teamsys.dnq.database.TransientSessionImpl.flush(TransientSessionImpl.java:1140)
at com.jetbrains.teamsys.dnq.database.TransientSessionImpl.intermediateCommitReturnChanges(TransientSessionImpl.java:774)
at com.jetbrains.teamsys.dnq.database.TransientSessionImpl.intermediateCommit(TransientSessionImpl.java:211)
at jetbrains.charisma.refactoring.RefactoringRebuildUniqueIndexes.apply(RefactoringRebuildUniqueIndexes.java:33)
at jetbrains.charisma.refactoring.Refactoring.applyRefactoring(Refactoring.java:79)
at jetbrains.charisma.refactoring.Refactoring.access$000(Refactoring.java:19)
at jetbrains.charisma.refactoring.Refactoring$1$1.visit(Refactoring.java:50)
at jetbrains.charisma.refactoring.Refactoring$1$1.visit(Refactoring.java:48)
at jetbrains.mps.internal.collections.runtime.IVisitor.invoke(IVisitor.java:14)
at jetbrains.mps.internal.collections.runtime.IterableUtils.visitAll(IterableUtils.java:17)
at jetbrains.mps.internal.collections.runtime.Sequence.visitAll(Sequence.java:85)
at jetbrains.charisma.refactoring.Refactoring$1.visit(Refactoring.java:48)
at jetbrains.charisma.refactoring.Refactoring$1.visit(Refactoring.java:46)
at jetbrains.mps.internal.collections.runtime.IVisitor.invoke(IVisitor.java:14)
at jetbrains.mps.internal.collections.runtime.IterableUtils.visitAll(IterableUtils.java:17)
at jetbrains.mps.internal.collections.runtime.Sequence.visitAll(Sequence.java:85)
at jetbrains.charisma.refactoring.Refactoring.applyAll(Refactoring.java:46)
at jetbrains.charisma.main.YouTrackInit.init(YouTrackInit.java:57)
at jetbrains.charisma.main.InitWebApplicationServiceLocatorListener.onAfterInit(InitWebApplicationServiceLocatorListener.java:9)
at jetbrains.springframework.configuration.runtime.ServiceLocator.fireLocalAfterInit(ServiceLocator.java:111)
at jetbrains.charisma.main.ServletImpl.init(ServletImpl.java:62)
at javax.servlet.GenericServlet.init(GenericServlet.java:244)
at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:1444)
at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:1071)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:189)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:595)
at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:98)
at com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:91)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:162)
at org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:330)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:231)
at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:174)
at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:828)
at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:725)
at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1019)
at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:225)
at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:137)
at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54)
at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:532)
at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
at java.lang.Thread.run(Thread.java:619)

7 comments
Comment actions Permalink

Hello Mike,

what was your previous version of YouTrack?

And what is the OS where YouTrack running?

0
Comment actions Permalink

The previous version was 3.0.4 and these are both running on windows server boxes

0
Comment actions Permalink

So I found out that the data will only open in 3.0.4. I have tried every version since and get the same error. I was wondering if using the python scripts to move from one Youtrack to another is an option and what I would lose in doing so?

We just introduced this to the rest of the dev groups in the company. I really hate to lose all this work and start the evaluation process all over again with another product.I loved the integration of IntelliJ, Team City and YouTrack. But if we can't reliably upgrade a minor version then it will be impossible to convince anyone else to use it.

0
Comment actions Permalink

Hello, Mike,

this Exception appeares in case that you tried to start YT 3.0.4 on DB after upgrade to 3.2.3.

Am I right?

0
Comment actions Permalink

I am not sure of the exact question you are asking. The situation is, I had a tomcat server go down(i thought it had 3.0.4) on it but not sure. Set up a different tomcat server and loaded 3.2.3 on it. I restored a backup to the new server.  I tried to open this with a  3.2.3 and it does not work (not sure if it "upgraded"). I reverted the war back to 3.0.4 and it woks, I tried every version and 3.0.4 is the only version it works with.

Let me summerize. I have a backup DB that works with 3.0.4 and it will not allow me to update to any other version. I am not sure what YT version was used to make the backup.

I hope this answers your question.

Thanks for your help.

0
Comment actions Permalink

mhilding wrote:

I tried to open this with a  3.2.3 and it does not work (not sure if it "upgraded").

"It doesn not work" - you mean at all?

Were you able to get any page of YouTrack?

We hadn't met such behaviour ever before.

If it is possible, cold you provide us your DB backUp so our developers could investigate it and provide a fix solution for you?

We have ftp://ftp.intellij.net server for uploads - it is write-only, so noone external will be able to see you DB.

0
Comment actions Permalink

Sergey,

Thanks for the quick reply.

When I start YT 3.4.3 with the backup database restored I do not get any part of YT to display.

We are currently using YT 3.0.4 in production. When it is figured out what the issue is can I send you the latest production backup so it can be repaired and we can keep our downtime to a minimum? Our users were none to happy with the down time on the 17th. Funny how quickly people become attached to a good peice of software.

separate issue:

To muddy the waters even more I will send you two backups one from 4/17 and one from 4/15. The reason i am sending you two is that the 4/17 backup reports an error when it is uncompressed. It still opens only in 3.0.4 and it appears all the data is there.  The 4/15 backup has no error when uncompressing but still only opens in 3.0.4.

Thanks for looking into this for me.

Mike

0

Please sign in to leave a comment.