Query Completion not working

I have recently made YouTrack externally visible, however when i access YouTrack via my external URL the query completion doesn't appear.

YouTrack is available via a statis IP and only port 80 has been opened.

Anyone any suggestions/ideas, do i need to do something in addition to make it work.

P.S if i access youtrack from within the domain, the query completion works.

Thanks
2 comments
Comment actions Permalink
Comments in this thread were accidently cleared due to a technical problem.

Here's the conversation restored from notifications:

YouTrack > Query Completion not working [ youtrack ] 7:10 am i.kate

Hello Thomas,

Could you please check the "baseURL" setting (Administration > Settings), it should be the same as your external URL.

If the baseURL is correct, and the problem still appear, could you please install e.g. Firebug and send us its console snapshot, while typing queries?

Best regards,
Kate

YouTrack > Query Completion not working [ youtrack ] 7:19 am thomas.anderson

<html>
<body>
<h3> Response denied by WatchGuard HTTP proxy. </h3>
<b> Reason: </b> header 'Content-Type' denied rule='Default' value='application/json' <br>
<hr size="1" noshade>
<b> Method: </b> GET <br>
<b> Host: </b> 81.145.137.175 <br>
<b> Path: </b> /rest/search/suggest?query=tag%3A%20%7BReady%20for%20Development%7D&amp;caret=0 <br>
<hr size="1" noshade>
</body>
<!– PAD –></html>

YouTrack > Query Completion not working [ youtrack ] 7:53 am i.kate

Thomas,

You need to correct your HTTP proxy settings so it'll accept application/json content.

Best regards,
Kate

0
Comment actions Permalink
Thanks kate.  I have raised an internal request for the IT guys to make the change.
0

Please sign in to leave a comment.