Youtrack gives me Service Inavailable error

I am running youtrack on an amazon instance with 3.7gb of ram. But after having it run for about an hour, i will get a service temp unavailable error when i try to access it via its url.

I use this command to run it

java -Xmx512m -Djava.awt.headless=true -jar youtrack-4.0.jar 8086


Any clues as to what may be "crashing" the java app?

I have java 1.6.0_24 installed
5 comments
Comment actions Permalink
Hello,

how large is your DB?
Is it anything suspicious in errors.log or youtrack.log files? Could you attachem them or send me by e-mail sergey.andreev at jetbrains.com ?
You said about crashing of java app - how you determine that it is crahsed?
0
Comment actions Permalink
The database is small, i just installed Youtrack and only have 6 issues currently.

I run the java command via SSH, and i monitor its output to see if I can track down that cause. But I notice that after a while, the java app stops listening to any new information (no new lines of information are being fed to me). At this points if i try to access youtrack.xx.com i get a service is unavailable error.

All I need to do to fix this, is open another SSH into the server and run the java command again. If Youtrack was still running, then it would be hogging up the port I set it to. This is how I figured that maybe java crashed and closed the Youtrack app.


I have attached the log files


youtrack.log (8.7MB)
errors.log (2.6MB)
0
Comment actions Permalink
Unfortunately logs didn't help.

1) Are there any files created like hs_err.pid after java fail?
2) Do you use any web-server as front-end?
3) Try to start java with  -XX:+HeapDumpOnOutOfMemoryError parameter, like:
java -Xmx512m -XX:+HeapDumpOnOutOfMemoryError -Djava.awt.headless=true -jar youtrack-4.0.jar 8086
It will create dump file in case of memory leaks.
0
Comment actions Permalink
Hello,

I figured out my issue. I was not executing Youtrack as a background service, so it made sense to expect Youtrack to terminate once my SSH session was closed.

I'm sorry for the inconvenience, and thank you so much for you help.
0
Comment actions Permalink
Glad to hear that problem is solved.
If you have any questions feel free to ask us.

Regards,
YouTrack team.
0

Please sign in to leave a comment.