Adding Git hub intergration to YouTrack...

Dear sirs:

I have a new YouTrack Project.  I try integrate Github to it.
I have commit rights to the repository.  But when i pick it out of the list of my Repositories, I get 'Not Found (404)' error.

When I click show repositories from other owners, and typoe in the Owner I get 'No matches'.

Is this a bug in your software?  
Or is the Github configuration bungled?

Jerry
10 comments
Comment actions Permalink
Hello Jerry,

Is your Github repository private? We had similar issue with private projects.

What YouTrack version do you use? If it's Stand-alone, please provide us with YouTrack logs. If it's InCloud, please tell us your instance URL name.

Thank you.
0
Comment actions Permalink
Hello,

Came across this as I'm experiencing the same issue.

Trying to add a 'private' Github repo to a project in our InCloud instance:  http://redwebdk.myjetbrains.com/

cheers,

tj
0
Comment actions Permalink
Link you sent me is requires login as you?????


Jerry

On 2013-07-01 15:58, Zaridan - YouTrack wrote:

*YouTrack <http://forum.jetbrains.com/forum/YouTrack> * > *Adding Git
hub intergration to YouTrack...
<http://forum.jetbrains.com/thread/YouTrack-1051> * [ *rest_api
<http://forum.jetbrains.com/tag/YouTrack-rest_api> * +*github
<http://forum.jetbrains.com/tag/YouTrack-github> * ] 4:57 pm
<http://forum.jetbrains.com/thread/YouTrack-1051?message=YouTrack-1051-2>
Zaridan <http://forum.jetbrains.com/user/Zaridan>

Hello,

Came across this as I'm experiencing the same issue.

Trying to add a 'private' Github repo to a project in our InCloud
instance: http://redwebdk.myjetbrains.com/

cheers,

tj

     Jerry Westrick <http://forum.jetbrains.com/user/westrick> @ Jun 24
     <http://forum.jetbrains.com/thread/YouTrack-1051>

     Dear sirs:

     I have a new YouTrack Project. I try integrate Github to it.
     I have commit rights to the repository. But when i pick it out of
     the list of my Repositories, I get 'Not Found (404)' error.

     When I click show repositories from other owners, and typoe in the
     Owner I get 'No matches'.

     Is this a bug in your software?
     Or is the Github configuration bungled?

     Jerry

JetBrains Forum | Build #171 (Jun/07/2013 10:26AM) | Feedback
<http://confluence.jetbrains.net/display/JETF/Feedback>
0
Comment actions Permalink
Hi Jerry,  

I was replying to this topic as I am having the same issue as you, and I provided the instance URL as requested by @andrey tigay.
0
Comment actions Permalink
Hi Jerry,

Did you check this http://forum.jetbrains.com/message/YouTrack-1051-1 ?

Hi Zaridan,

I've replied to your email request. Seems, you've met another problem.

Thank you.
0
Comment actions Permalink
I am using the InCloud version.  It is a private GitHub repository.
0
Comment actions Permalink
Jerry,

Please, confirm that you are Github repo owner. If you are not, then check that your Github user has access permissions to Service Hook settings. Take a look at this issue and this comment http://youtrack.jetbrains.com/issue/JT-17349#comment=27-439575 .
And unfortunately, you haven't provide us with your instance URL name in your last reply.

Thank you.
0
Comment actions Permalink
instance is westrick
I am not owner,
will check permisions,
which is probably the problem
will return with results...

Jerry
0
Comment actions Permalink
I have the same issue. I am the github owner of the repository in question. I can connect to it using YouTrack stand alone (uses login credentials), but when I try to connect to it from YouTrack InCloud (using and OAuth token) I oly see the public repositories and cannot connect to a private GitHub repository...
0
Comment actions Permalink
Andrey

Same problem using private repository on github, i create an oauth token and get no "matches" on response.  i'm using version 5.2.3-8810.
Can you help me?
0

Please sign in to leave a comment.