translating YouTrack EAP not successful

Hi, I'm trying to translate YouTrack EAP version to my native language, but not successful.

YouTrack version: build #7076
Following instructions at: http://confluence.jetbrains.com/display/YTD5/Translating+YouTrack+UI


My questions are:

1. Where is supportedLocales.xml?
I searched the directory and found one under directory <YouTrack dir>\work\Catalina\localhost\_\WEB-INF\classes\translations, but I'm not sure if it is the right one, because my modifications to it always lost after the service restart.

2. Where should I put the translation files?
Should I put them in the \WEB-INF\classes\translations directory, just as others, or should I put it in a directory outside YouTrack directory and define "Djetbrains.mps.webr.i18n.custom-translations" property which point to it?

3. What is the correct custom-translations directory layout?
According the instruction:
java -Djetbrains.mps.webr.i18n.custom-translations=/home/vadim/youtrack-i18n -jar youtrack.jar 8080

Should the actual file layout be
=/home/vadim/youtrack-i18n/all_xx.properties
or
=/home/vadim/youtrack-i18n/<local_id>/all_xx.properties
?

4. Should I restart service or juest click reload messages to take the modifications in effect?

5. I could not see my locale in the language drop down, looking into logs/errors.log also give me no idea. Where could I troubleshooting the translation process?
2 comments
Comment actions Permalink
Hi,

You should create a directory and provide path to it via -Djetbrains.mps.webr.i18n.custom-translations parameter to YouTrack. The directory should contain supportedLocales.xml file with single localeEntry for your language (or multiple if you are adding more languages). Also the directory should contain subdirectory named ll_CC where ll stays for a language code and CC for a country code (for example fi_FI for Finnish). See http://docs.oracle.com/javase/6/docs/api/java/util/Locale.html for details. That ll_CC directory should contain files with localized messages.
So the directory structure should look like this:
myCustomLocalizations
  fi_FI
    messages_fi.properties
  supportedLocales.xml
prettyPrint();
0
Comment actions Permalink
Great! I can see my translation in effect now. Thank you for your reply.
0

Please sign in to leave a comment.