Can't access from Internet

Hi all.

I've just installed YouTrack. It works on port 90. Everything is prettygood in LAN, but when I try to get access from Internet, I get nothing.
I've opened port on windows firewall and even tried to turn it off. Also I've mapped port 90 on my router.
Telnet successfully connects on port 90 from Internet.

What else should I do to get access to YT from Internet?

Thanks in advance.
5 comments
Comment actions Permalink
Hello Tyler,

Please, confirm that you can reach the server from the internet.
Try again with disabled firewall and antivirus software.
What did you get when try to access the YouTrack by the URL:
http://<server_address>:90 ?

Is there any server at the top in your network configuration, like Nginx or other?

In general, the only condition to access YouTrack, is to make you server available for external internet.

Thank you.
0
Comment actions Permalink
Hello Andrey,

I still can't access to YT from the internet.
My server is after the router and I have mapped port 90.
I did same thing for my website supported by IIS (port 80) and everything works fine.
When I try access YT from LAN - everything works.
When I try access YT from the internet I've got an http 500 error.
HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.


Port 90 is opened on firewall. I tried turn off the firewall and got the same effect. I've got no any AV software on that server.
0
Comment actions Permalink
Tyler,

How did you configure a port forwarding on your router? It must be configured so that all request come from the internet to 90th port should be redirected to your local server where YouTrack installs.
May I kindly ask you to test YouTrack with 80th port? To change the port, please take a look at this reference http://confluence.jetbrains.com/display/YTD5/Changing+Port+for+YouTrack+Windows+Service

Thank you.
0
Comment actions Permalink
I've changed port to 80, but I've got message
Not Found

HTTP Error 404. The requested resource is not found.
0
Comment actions Permalink
I've reinstalled YT on other PC and have the same issue: I can access YT from LAN, but I can't access from the internet. Port forwarded properly (I tested with other software run on that port and everything worked fine).
telnet myInetAddress myYTport connects, but browser not.
Do you have any other suggestions what I have to do to make YT work?

Thanks
0

Please sign in to leave a comment.