Youtrack behaves weard behind nginx

Hi there
I have Youtrack 5 installed behind a nginx reverse proxy. At first sight, you might think, everything is ok, but when you e.g. open an issue, the whole comments section is missing (attached picture). Also you cannot edit issues. My nginx config looks like this:

server {
        listen 443 ssl;
        server_name [censored];

        ssl_certificate [censored];
        ssl_certificate_key [censored];
        ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2;

        proxy_connect_timeout 300;
        client_max_body_size 10m;

        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_pass_header Set-Cookie;
        proxy_pass_header Date;
        proxy_pass_header Server;

        location / {
access_log /var/log/nginx/youtrack.log;
#proxy_set_header Host $http_host;  ##nothing works, when this is enabled
proxy_pass http://10.86.50.10:8000/;
        }


I have followed this documentation:
http://confluence.jetbrains.com/display/YTD2/Linux.+JAR+in+Nginx+Web+Server

I also changed the base url to: https://[censored server_name above]

Any ideas what's missing?


youtrack_issue.png
1 comment
Comment actions Permalink
it seems that all ajax traffic breaks. loading the js files takes a few seconds. also there are a lot of javascript errors (null references) when connecting through nginx.
on the other side, i can reverse proxy other java applications like the zimbra webmail without problems.
0

Please sign in to leave a comment.