Import data from BugZilla in YouTrack

Good afternoon, we have Bugzilla, which uses a database PostgresSQL, I downloaded a python script to synchronize YouTrack and Bugzilla, he can only work with of MySQL, how to transfer data when using Bugzilla PostgreSQL?
14 comments
Comment actions Permalink
Hello Vasiliy,

You're able to make an export from PostgresSQL to MySQL script (via MySQLDump), insert resulting script to import script and run it again.

Let me know if need an assistance with this.
0
Comment actions Permalink
Of course this can be done, but it requires time, you do not plan to modify the script to support other databases?
0
Comment actions Permalink
Vasiliy,

Unfortunately, support of the other databases weren't planned for the nearest future.
Currently, there are several available workarounds for this and that one I've provided to you seems to be rather evident and easy.  

Please note, you are welcome to contact us if need an assistance with this.
0
Comment actions Permalink
I have a problem with the script, I converted the database, ordered in such a configuration script

    target_url = "http://192.168.24.50:8080"
    target_login = "root"
    target_pass = "my_pass"
    bz_db = "bugs"
    bz_host = "localhost"
    bz_port = 3306
    bz_login = "root"
    bz_pass = "my_pass"
    bz_product_names = []

in the end the script does not give errors, and does not show any message

root@Golodnyi-Work:# python ./bugzilla2youtrack.py
root@Golodnyi-Work:#

data does not fall into youtrack, in what could be the problem?
0
Comment actions Permalink
I understood the problem, the script should comment out some code if you want that taken from the config settings, not as parameters to the script
0
Comment actions Permalink
root@Golodnyi-Work:/tmp/youtrack-rest-python-library-master/python# python ./bugzilla2youtrack.py
All projects will be imported. Are you sure? [y/n]y
bz_product_names :   ['\xd0\x9e\xd1\x82\xd1\x87\xd0\xb5\xd1\x82\xd0\xbd\xd0\xbe\xd1\x81\xd1\x82\xd1\x8c Datacrypt', '\xd0\xad\xd0\x94\xd0\x9e Datacrypt', '\xd0\xa3\xd0\xa6', 'uslugi', '\xd0\x91\xd0\xb8\xd0\xbb\xd0\xbb\xd0\xb8\xd0\xbd\xd0\xb3', 'finance-book', '\xd0\x94\xd1\x80\xd1\x83\xd0\xb3\xd0\xb8\xd0\xb5', 'tahograf', 'Applet']
Creating issue link types
Creating issue link types finished
Creating custom fields
Creating custom fields finished
Creating project [ 2 ] with name [ Отчетность Datacrypt ]
Importing components for project [ 2 ]
Importing components finished for project [ 2 ]
Importing versions for project [ 2 ]
Importing versions finished for project [ 2 ] finished
Importing issues to project [ 2 ]
Traceback (most recent call last):
  File "./bugzilla2youtrack.py", line 355, in <module>
    main()
  File "./bugzilla2youtrack.py", line 36, in main
    bz_product_names, lambda issue: True)
  File "./bugzilla2youtrack.py", line 306, in bugzilla2youtrack
    batch = client.get_issues(product_id, from_id, from_id + max_count)
  File "/var/www/admin-client.loc/www/youtrack-rest-python-library-master/python/bugzilla/bzClient.py", line 140, in get_issues
    row["keywords"] = set([kw.strip() for kw in row["keywords"].split(",") if len(kw.strip())])
KeyError: 'keywords'
root@Golodnyi-Work:/var/www/admin-client.loc/www/youtrack-rest-python-library-master/python#

?
0
Comment actions Permalink
the problem is solved, the data transferred =)
0
Comment actions Permalink
Vasiliy,

Import from Bugzilla operates in following way:
after import, all issues in YouTrack have default State - Submitted and both custom fields (which were inherited from Bugzilla) - Status and Resolution.
Resolved value can be found under the Status custom field.

Thank you.
0
Comment actions Permalink
I do not think that this is the correct behavior ... The main task status was must inherited from bugzilla, otherwise obtained thousands of open tasks that have already been executed.
Either I did not understand correctly the ideology of working with youtrack?
0
Comment actions Permalink
Vasiliy,

Possible inconvenience are connected with different State/Status/Resolution scheme in Bugzilla and in YouTrack.
Taking into account experience of using the import script, we decided to move to the current scheme and leave all fields in just created issues from Bugzilla. This way allows you to search for issues by previous Status and Resolution fields and values.
It's impossible to match states from these both issue-trackers objectively because YouTrack has only one State field and Bugzilla has two of them with almost similar values.
Now, you have all issues with original Bugzilla Statuses and Resolutions. If this it breaks you process now, you can just filter all issues by Status: Resolved, select all issues and apply batch command State: Fixed (start typing this command on issue list, command window will be called)  

Let me know, if have any further questions.
0
Comment actions Permalink
there is still one question =) I do backups through the admin panel, which gives the size of the archive 3Mb, I have about 1,000 errors and hundreds of attached files, these 3Mb can hold only text information, the system backup of not added attached files? Where location attached file in filesystem?


Born the second question I want to put the system at mydomain.com / youtrack this is only possible through mod_proxy or redirect? I can not install on a specific address on port 80?
0
Comment actions Permalink
the third question, I installed youtrack as Apache module, when the file I give it to the server customized final 10mb, the file is larger than the max size of the  server, where change value of max size? not in the php.ini, because the application in java
0
Comment actions Permalink
Hi Vasiliy,

May I know how you solve this problem? I am getting the same error and unable to import my Bugzilla into YouTrack.
0

Please sign in to leave a comment.