Unable to create an issue on the agile board.

I've create a couple new projects and an Agile board.
One project I use for User stories and the other project is for a module in the application.

I created a swim lane on the agile board and associated it with a sprint.

When I go to create an issue in that swim lane I get the following error:

Cannot create issue in the current sprint, because there is no 'Sprint 12' version in the 'VPower-Forecast' project.You should add value 'Sprint 12' for field 'Fix versions' in the project.


I went to the setting for the project but saw no place where I can configure fix versions. Where to I go to fix this?
5 comments
Comment actions Permalink
Hello,

Am I correct with that, you've created a board and add two projects to the board and choose 'Fix version' in field to identify a swimlane?
Navigate to Administration-> Projects-> target project-> Fields tab-> Fix version-> click on Fix version value bundle and add needed version.

Thank you.
0
Comment actions Permalink
I added the first project ("User Stories") to the board as a swim lane.
Within that swimlane, I selected "Create new task" and selected another
project for that task ("Project X"). When I went to save it, I received
that error.




On 12/5/13 6:54 AM, andrey tigay - YouTrack wrote:

*YouTrack <http://forum.jetbrains.com/forum/YouTrack> * > *Unable to
create an issue on the agile board.
<http://forum.jetbrains.com/thread/YouTrack-1341> * 6:53 am
<http://forum.jetbrains.com/thread/YouTrack-1341?message=YouTrack-1341-1>
andrey tigay <http://forum.jetbrains.com/user/andrey.tigay>

Hello,

Am I correct with that, you've created a board and add two projects to
the board and choose 'Fix version' in field to identify a swimlane?
Navigate to Administration-> Projects-> target project-> Fields tab->
Fix version-> click on Fix version value bundle and add needed version.

Thank you.



Regards,

Andrey Tigay
YouTrack engineer

     aiacovella <http://forum.jetbrains.com/user/aiacovella> @ Dec 04
     <http://forum.jetbrains.com/thread/YouTrack-1341>

     I've create a couple new projects and an Agile board.
     One project I use for User stories and the other project is for a
     module in the application.

     I created a swim lane on the agile board and associated it with a
     sprint.

     When I go to create an issue in that swim lane I get the following
     error:

     Cannot create issue in the current sprint, because there is no
     'Sprint 12' version in the 'VPower-Forecast' project.You should
     add value 'Sprint 12' for field 'Fix versions' in the project.


     I went to the setting for the project but saw no place where I can
     configure fix versions. Where to I go to fix this?

JetBrains Forum | Build #173 (Sep/19/2013 4:50PM) | Feedback
<http://confluence.jetbrains.net/display/JETF/Feedback>
0
Comment actions Permalink
From the error, I see that the project name is 'VPower-Forecast'.
Anyway, please add Fix version value to 'Project X'(or to project where the value is needed) as I've described it above.

Thank you.
0
Comment actions Permalink
Ok so I did that but here is what doesn't make sense.  The filter in the
Agile board is supposed to be for sprints. I now see the fix version
showing up as an option for filtering. Why does a version exist in the
filter option for sprints? Shouldn't it be a sprint name like Sprint 19
as opposed to a project version?


On 12/5/13 7:55 AM, andrey tigay - YouTrack wrote:

*YouTrack <http://forum.jetbrains.com/forum/YouTrack> * > *Unable to
create an issue on the agile board.
<http://forum.jetbrains.com/thread/YouTrack-1341> * 7:54 am
<http://forum.jetbrains.com/thread/YouTrack-1341?message=YouTrack-1341-3>
andrey tigay <http://forum.jetbrains.com/user/andrey.tigay>

From the error, I see that the project name is 'VPower-Forecast'.
Anyway, please add Fix version value to 'Project X'(or to project
where the value is needed) as I've described it above.

Thank you.


Regards,

Andrey Tigay
YouTrack engineer

     aiacovella <http://forum.jetbrains.com/user/aiacovella> @ 7:13 am
     <http://forum.jetbrains.com/thread/YouTrack-1341?message=YouTrack-1341-2>


     I added the first project ("User Stories") to the board as a swim
     lane.
     Within that swimlane, I selected "Create new task" and selected
     another
     project for that task ("Project X"). When I went to save it, I
     received
     that error.




     On 12/5/13 6:54 AM, andrey tigay - YouTrack wrote:

     *YouTrack <http://forum.jetbrains.com/forum/YouTrack> * > *Unable to
     create an issue on the agile board.
     <http://forum.jetbrains.com/thread/YouTrack-1341> * 6:53 am
     <http://forum.jetbrains.com/thread/YouTrack-1341?message=YouTrack-1341-1>

     andrey tigay <http://forum.jetbrains.com/user/andrey.tigay>

     Hello,

     Am I correct with that, you've created a board and add two
     projects to
     the board and choose 'Fix version' in field to identify a swimlane?
     Navigate to Administration-> Projects-> target project-> Fields tab->
     Fix version-> click on Fix version value bundle and add needed
     version.

     Thank you.



     Regards,

     Andrey Tigay
     YouTrack engineer

     aiacovella <http://forum.jetbrains.com/user/aiacovella> @ Dec 04
     <http://forum.jetbrains.com/thread/YouTrack-1341>

     I've create a couple new projects and an Agile board.
     One project I use for User stories and the other project is for a
     module in the application.

     I created a swim lane on the agile board and associated it with a
     sprint.

     When I go to create an issue in that swim lane I get the following
     error:

     Cannot create issue in the current sprint, because there is no
     'Sprint 12' version in the 'VPower-Forecast' project.You should
     add value 'Sprint 12' for field 'Fix versions' in the project.


     I went to the setting for the project but saw no place where I can
     configure fix versions. Where to I go to fix this?

     JetBrains Forum | Build #173 (Sep/19/2013 4:50PM) | Feedback
     <http://confluence.jetbrains.net/display/JETF/Feedback>

JetBrains Forum | Build #173 (Sep/19/2013 4:50PM) | Feedback
<http://confluence.jetbrains.net/display/JETF/Feedback>
0
Comment actions Permalink
Ok I'm able to add them now but for the fix version the project has to
have a version in the bundle that matches the sprint name. How do I
configure issues then to map the to a specific release version such as
1.0.0?



On 12/5/13 7:55 AM, andrey tigay - YouTrack wrote:

*YouTrack <http://forum.jetbrains.com/forum/YouTrack> * > *Unable to
create an issue on the agile board.
<http://forum.jetbrains.com/thread/YouTrack-1341> * 7:54 am
<http://forum.jetbrains.com/thread/YouTrack-1341?message=YouTrack-1341-3>
andrey tigay <http://forum.jetbrains.com/user/andrey.tigay>

From the error, I see that the project name is 'VPower-Forecast'.
Anyway, please add Fix version value to 'Project X'(or to project
where the value is needed) as I've described it above.

Thank you.


Regards,

Andrey Tigay
YouTrack engineer

     aiacovella <http://forum.jetbrains.com/user/aiacovella> @ 7:13 am
     <http://forum.jetbrains.com/thread/YouTrack-1341?message=YouTrack-1341-2>


     I added the first project ("User Stories") to the board as a swim
     lane.
     Within that swimlane, I selected "Create new task" and selected
     another
     project for that task ("Project X"). When I went to save it, I
     received
     that error.




     On 12/5/13 6:54 AM, andrey tigay - YouTrack wrote:

     *YouTrack <http://forum.jetbrains.com/forum/YouTrack> * > *Unable to
     create an issue on the agile board.
     <http://forum.jetbrains.com/thread/YouTrack-1341> * 6:53 am
     <http://forum.jetbrains.com/thread/YouTrack-1341?message=YouTrack-1341-1>

     andrey tigay <http://forum.jetbrains.com/user/andrey.tigay>

     Hello,

     Am I correct with that, you've created a board and add two
     projects to
     the board and choose 'Fix version' in field to identify a swimlane?
     Navigate to Administration-> Projects-> target project-> Fields tab->
     Fix version-> click on Fix version value bundle and add needed
     version.

     Thank you.



     Regards,

     Andrey Tigay
     YouTrack engineer

     aiacovella <http://forum.jetbrains.com/user/aiacovella> @ Dec 04
     <http://forum.jetbrains.com/thread/YouTrack-1341>

     I've create a couple new projects and an Agile board.
     One project I use for User stories and the other project is for a
     module in the application.

     I created a swim lane on the agile board and associated it with a
     sprint.

     When I go to create an issue in that swim lane I get the following
     error:

     Cannot create issue in the current sprint, because there is no
     'Sprint 12' version in the 'VPower-Forecast' project.You should
     add value 'Sprint 12' for field 'Fix versions' in the project.


     I went to the setting for the project but saw no place where I can
     configure fix versions. Where to I go to fix this?

     JetBrains Forum | Build #173 (Sep/19/2013 4:50PM) | Feedback
     <http://confluence.jetbrains.net/display/JETF/Feedback>

JetBrains Forum | Build #173 (Sep/19/2013 4:50PM) | Feedback
<http://confluence.jetbrains.net/display/JETF/Feedback>
0

Please sign in to leave a comment.