Recover from YouTrack Reset

We have been using YouTrack successfully for nearly two years now, and to my astonishment this morning when we go to the internal website of YouTrack we get the "Welcome, root! Please start configuring YouTrack 4.1.2 settings." message along with the licence agreement text, user & email settings etc.

Does that mean the installation somehow got wiped out / reset and it thinks it's a brand new install? What about our data? What are the steps to attempt a recovery of it?

The version we use is 4.1.2, don't think we had any database backups, however I can look through historic server image backups, but need to know what to look for!

Any help is greatly appreciated.

Best regards
Andy
7 comments
Comment actions Permalink
Hi
I also had this a while ago, but that was after changing the service user to be able to backup to a network share.
I could solve it by changing back the user or moving the data folder (teamsysdata) to the users folder (on recent windows versions: c:\users\username\teamsysdata)
0
Comment actions Permalink
Is all data included in the teamsysdata folder? On our server it actually resides directly on C:\ drive, I have tried copying it into the user folder but nothing changed... Should I perhaps continue setting up YouTrack and then overwrite this folder?
0
Comment actions Permalink
All data is in the teamsysdata folder. Best to make a copy of that folder.
Is the user folder you copied the teamsysdate to the same as the user of the "Youtrack Web Server"-service?
If it still doesn't work, you can change the user of the service back to "local system" and move the teamsysdata to C:\.
Or if you re-install Youtrack, the service user will be back to the defaut value.
0
Comment actions Permalink
The "YouTrack Web Server" service is started as Local System, so it seems that it was already reading from C:\teamsysdata... Any other ideas?
0
Comment actions Permalink
Restore a working backup?
Other support will have to come from Jetbrains I think.
0
Comment actions Permalink
Hi Andy,
we had the exact same issue with the version 5.0.6 and we found a workaround.
Maybe it helps you, in case you could not already solve your problem... hope it works with your version also...
http://forum.jetbrains.com/thread/YouTrack-1415
Regards
0
Comment actions Permalink
This did the trick! Thanks very much!!
0

Please sign in to leave a comment.