Screenshot applet throws exception: Can't find bundle for base name applet, locale de

We are running self hosted Youtrack 5.

When the server runs english we can run the "screenshot" applet and the "attach image from clipboard" applet.

When we translato to german, a java error is thrown locally:

java.util.MissingResourceException: Can't find bundle for base name applet, locale de
java.util.MissingResourceException: Can't find bundle for base name applet, locale de
 at java.util.ResourceBundle.throwMissingResourceException(Unknown Source)
 at java.util.ResourceBundle.getBundleImpl(Unknown Source)
 at java.util.ResourceBundle.getBundle(Unknown Source)
 at jetbrains.charisma.jetshot.light.q.A(Unknown Source)
 at jetbrains.charisma.jetshot.light.JetShotApplet._init(Unknown Source)
 at jetbrains.charisma.jetshot.light.JetShotApplet.L(Unknown Source)
 at jetbrains.charisma.jetshot.light.JetShotApplet.init(Unknown Source)
 at com.sun.deploy.uitoolkit.impl.awt.AWTAppletAdapter.init(Unknown Source)
 at sun.plugin2.applet.Plugin2Manager$ Source)
 at Source)
Comment actions Permalink

we also have a big problem with screenshot/java!

We use YouTrack InCloud 5.1 in German.

In version 5.0x we had the problem that every 2. time this Java Error was shown:

The next time we tried to insert a screenshot via Clipboard, it worked. That was annoying but it worked...

Since Update to YouTrack 5.1 we get this Error every time!
We already checked Java Settings and tried some solutions like Deployment Rulesets (, but nothing solved our problem.

Today we can only add screenshots via "attach file", which is very annoying. :-(

@ Jetbrains staff:
Pleas fix this problem soon.

Comment actions Permalink
Dear Youtrack support,

could you please look into this?

It would be really cool to run YouTrack localized at last. This is a killer feature.

But currently we can only run english, because of the Screenshot Applet issue mentioned above.

It seems in this thread 3 people are already having this problem.

Can you reproduce the error? Just in case this is not easy to reproduce, I could offer to your technical staff to give root access to our self hosted server (12.04 LTS on aws) where youtrack 5 is running and produces the error.
Comment actions Permalink
Actually what Thorsten is describing is the same behaviour that we have.

The exception stack trace in my initial message above was only visible after some fiddling with the java debug settings in windows.

So I am quite sure this is the same error or at least closely related.

Please sign in to leave a comment.