Reassign Admin role to root

I've just done something really stupid in YouTrack and don't how to backtrack. What have I done? Removed the 'Admin' role from root!!

No one has the permissions to put it back! Is there a way to assign the admin role to root on the command line or somewhere else outside of the application (UI)?


Windows 7 Installation running as a Windows Service version 5.1
3 comments
Comment actions Permalink
As part of our evaluation of this product it is becoming apparent that there is no support available, either directly or through external forums. Shame really because I really like the product, but if we cannot get support then it is not worth the money and certainly not a viable option.

Time to uninstall and move on ...
0
Comment actions Permalink
Sorry for the long delay in replying,

you can restore root's password by the restarting YouTrack with the option -Djetbrains.charisma.restoreRootPassword=true.

Please see details in the documentation.
0
Comment actions Permalink
I've Tried that along with several other things. You can see here (http://stackoverflow.com/questions/22503247/how-to-assign-admin-role-to-root/22748567?noredirect=1#22748567) that I have actually received some help from people in the community. unfortunately I have since 'killed' the app (error message on SO post, something about Session tokens).

The main problem I have is that I convinced by Boss that this was a good product and convinced him to actually part with some cash for it (luckily we haven't!). Now, I look stupid because we have a dead app with our old wonderdesk tickets trapped inside. Every time my Boss asks "How's the new issue tracker" I have to say "Still no reply". I do accept that I created this issue in the first place but dumb users should not be enemy of smart software.

While one part of me thinks, "Just reinstall and enter all the tickets again", I'm very sceptical that moving forward we can gain worthwhile support (I am surprised though, JetBrains have always been good to me in the past).

Anyway thanks for your help but I think in this case it's maybe too little too late.
0

Please sign in to leave a comment.