Hour check not working in scheduler

I want to add comments to a Show Stopper bug that has not been updated in 8 hours. This is the code:

schedule rule showstopper update check 
 
hourly at 00:00 [issue.resolved == null && issue.Priority == {Show-stopper} && issue.updated < now - 8 hours] { 
  addComment("Show Stopper issue not updated in last 8 hours. Please update with the current status or downgrade bug to Critical."); 
  issue.Assignee.notify("Show-Stopper notification #" + issue.getId() + " Pending", "You have not updated the show stopper issue " + issue.getId() + " in last 8 hours! Please update with current status or downgrade bug to Critical."); 
}
prettyPrint();

However it doesn't seem to be working for me. What am I doing wrong?
1 comment
Comment actions Permalink
  1. Better to use State.isResolved instead of issue.resolved
  2. If the workflow rule maintainer (uploader) is the same user as the 'Assingee' and this user hasn't checked the option 'Receive notification on my own changes' in the profile > 'Filters and Notifications' then he won't get notification.
If so please either enable the mentioned above setting or use the method notify("title", "subject", true).
0

Please sign in to leave a comment.