Workflow error

Привет, ребят!
Имею вот такой workflow:
schedule rule change state to Closed if task do not updated more than 30 days 
 
daily at 08:05:00 [issue.State.isResolved && issue.State == {Verified} && issue.updated < now - 30 days] { 
  issue.State = {Closed}; 
}
prettyPrint();

После редактирования и загрузки его в систему, он почему-то не появляется в списке доступных к работе. Ранее (пару месяцев назад) правило работало. При этом в редакторе следующие ошибки (скрин)

youtrack4.0_youtrack-workflow.jpg

youtrack4.0_youtrack-workflow]2 .jpg
10 comments
Comment actions Permalink
А Workflow Editor показывает ошибки?
0
Comment actions Permalink
В коде? нет.
outrack4.0_youtrack-workflow] .jpg
0
Comment actions Permalink
Попробуйте залить этот воркфлоу, используя Action "Force upload", который доступен в контекстном меню для воркфлоу в дереве воркфлоу.
0
Comment actions Permalink
Ну я так и заливаю всегда..
0
Comment actions Permalink
Судя по прикрепленным скриншотам ошибок в самом воркфлоу нет. Прикрепите, пожалуйста, скриншот, на котором вы ожидаете увидеть этот воркфлоу, а его нет.
0
Comment actions Permalink
Чутка пришлось замазать по безопасности.
YouTrack111.jpg
0
Comment actions Permalink
Попробуйте удалить все воркфлоу из Workflow Editor и выкачать из заново из Ютрека. А после этого залить ваш обратно.

Только лучше предврительно сделайте бекап всех нужных воркфлоу.
0
Comment actions Permalink
Неа, не прокатило. Прикреплю аттачем файлы самого workflow.. Почему то есть ощущение, что баг вылезает на моменте генерации html
change+state+to+Closed+if+task+do+not+updated+more+than+30+days.html (3.9KB)
change+state+to+Closed+if+task+do+not+updated+more+than+30+days.js (682B)
trace.info (29KB)
change+state+to+Closed+if+task+do+not+updated+more+than+30+days.js (682B)
dependencies (261B)
generated (3.2KB)
1toclosed.mps (8.6KB)
0
Comment actions Permalink
Приложите, пожалуйста, весь zip архив этого воркфлоу, иначе я не смогу импортировать его в свой WFE и понять, где ошибка.
0
Comment actions Permalink
Вообщем, проблему решил переустановкой editor'а
0

Please sign in to leave a comment.