CSV export breaks with description content containing newlines

When I try to export some issues from a project, which contain a description text containing multiline text, the CSV format is broken.
The description text which contains a newline or carriage return or whatever to break into a newline, is also a newline in the CSV.
This behaviour breaks the CSV format, and makes it not readable.

Any suggestions on this? Is this a (already) known bug? What can I do against it?

I am on a Ubuntu, using gedit to open the CSV or Calc to format the csv into columns.

THanks
5 comments
Comment actions Permalink
Official comment

Hello, I'm sorry for the delay.

We've just tested this case with Calc, you need to configure the settings like this to open the file properly:

 

Please let us know if that helps. Thank you.

Comment actions Permalink

Hello,

This problem is still present, how can I solve it?

0
Comment actions Permalink

Hello,

I also experience the above issue when importing the csv to a Win10, MS Excel 365. I use unicode utf-8, comma separation.
It's not clear if it's an export bug or some additional setting is needed during import?

Thanks

0
Comment actions Permalink

Dear Liubova,

Thank you for the fast response!

I simply opened the CSV file using the Wizard (File -> Open ..) method wit UTF-8 coding. This way the Excel 365 on Win 10 (Hun locale) opens the CSV incorrectly. I tried several codings but the text import is incorrect.
In the CSV file new records are delimited by 0x0D 0x0A and new line by 0x2E 0x0A. This is not detected correcly, and I don't know the reason.

comma separated:

 

However, using the (Data -> Import text or CSV .. menu), I managed to correctly import the (dummy) records and newlines in the Description fields.

The data import method solved my problem.

Best regards,
Arpad 

0

Please sign in to leave a comment.