YouTrack 6 Stand alone server Dashboard issue :::: SOLVED

I can create and save a new widget to my dashboard. While I am on the page it works. When I leave the dashboard view and then return, my newly saved widgets are gone. Any ideas on how to fix this?

Also, I have added notes to the notes widget. They show up in the edit mode but not in the full dashboard. Again, any help would be appreciated.
4 comments
Comment actions Permalink
Hello Randy,

Do you observe this on your InCloud instance or Stand-alone (provide the build number, please)?
Does this happen after reloading the page? Were you became logged out?

Thank you.
0
Comment actions Permalink
Hello Andrey,

We are running the standalone server for you track version 6.

JetBrains Bug & Issue Tracker YouTrack 6.0
Build 12124 [30-Oct-2014 22:27]

Here are the steps that I took:

From the dashboard page, add a widget -> YouTrack Issues. I filled out the information. The widget appears on the dashboard.
I clicked on the issues link.
Clicked on the dashboard icon and the previously created widget was gone.
I tried the previous steps again except that I logged out after creating the widget. When I logged back in, the widgets that I had created were gone.
0
Comment actions Permalink
Randy,

Thanks for the details.
We haven't been able to reproduce this yet. However, since YouTrack 6.0 release, we've fixed a lot of issues on dashboard, the build will be delivered very soon. I kindly ask you to check new build and let me know if the issue still remains.

Stay tuned.
0
Comment actions Permalink
Andrey,

The problem is solved. Turned out to be mod_security blocking YouTrack's JSON requests to the backend.

--randy
0

Please sign in to leave a comment.